PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Gelöst Mail-Schutz funktioniert unter Win7 nicht mehr und zerstört Thunderbird Profil



Herzmann
02.06.13, 01:44
Hallo,

ich habe mein Thunderbird-Profil von Win XP nach Win 7 "umgezogen". Auf beiden Rechnern ist die aktuelle avast!-Version und der Mail-Schutz aktiviert. Ich benutze SSL/TLS-Verschlüsslung.
Nun kann ich auf dem Win7-Rechner weder E-Mails abrufen, noch versenden.
Erst das Abschalten des avast! Mail-Schutz löste die Blockade auf, und da waren dann meine lokalen IMAP-E-Mails erst mal gelöscht.
Näheres habe ich hier beschrieben: http://www.thunderbird-mail.de/forum/viewtopic.php?f=27&t=63066

Gibt es da schon Erfahrungen, woran das liegt, und wie man den Fehler behebt?

Elektro
02.06.13, 15:00
Hallo, ich und andere hatten ein Problem mit dem Mailschutz und dem abholen und senden von Mails.
Kommt oder kamen bei dir irgendwann Meldungen mit ungültigen Zertifikaten ...
Dann siehe hier http://forum.avadas.de/threads/5495-eMail-Schutz-geht-nicht-mehr

Herzmann
02.06.13, 15:35
Erst mal herzlichen Dank Elektro, dass Du auf diesen Thread aufgesprungen bist.
Ich kann mich dunkel an Meldungen mit ungültigen Zertifikaten erinnern, bin aber keinesfalls mehr sicher.
Wenn ich es richtig verstehe, sorgt avast! dafür, dass die richtigen Zertifikate bei Windows eingetragen werden, nicht aber für deren Kopie nach Thunderbird.
Besteht die Möglichkeit, dass avast! das in einem späteren Update noch "erledigt"?
Vielleicht sorgen auch die Leute von Thunderbird gelegentlich dafür, was aber sicher dauern wird, wie ich die kenne.
Dann würde ich einfach mal eine Zeit ohne den Mail-Schutz weiterarbeiten, denn das manuelle Kopieren erscheint mir doch kompliziert und fehlerträchtig.

Was mich noch wundert, warum das auf dem XP-Rechner bisher keine Probleme gab, denn da habe ich ja auch das neueste avast! 8 drauf.

Elektro
02.06.13, 16:08
Hallo Herzmann, so kompliziert ist es auch nicht wenn man erst mal damit anfängt. Nur sind das lange Anleitungen ...
Im ersten schritt exportierst du das Zertifikat auf den Desktop.
Damit ist schon ein Großteil der Anleitung erledigt.
Beim exportieren kann eigentlich wenig falsch laufen.

Hallo Adama wenn du das lesen solltes.
Ist es nicht möglich in der Anleitung das Zertifikat (mit Datum wegen Aktualität) als Anhang zum Download anzubieten? Oder greift hier Copy Recht?
Dann würde das für viele Einsteiger einfacher werden.

Herzmann
02.06.13, 16:37
Hallo Adama wenn du das lesen solltes.
Ist es nicht möglich in der Anleitung das Zertifikat (mit Datum wegen Aktualität) als Anhang zum Download anzubieten? Oder greift hier Copy Recht?
Dann würde das für viele Einsteiger einfacher werden.

Coole Idee, danke!
Wenn das nichts wird, werde ich mich wohl mal an das Prozedere ranmachen (müssen).

Herzmann
03.06.13, 14:49
Evtl. sind die Zertifikate auf unterschiedlichen Rechnern aber auch unterschiedlich, z.B. aus Zufallswerten erzeugt, was den vorgeschlagenen Download absurd machen würde.
Kann das mal jemand klären, Adama vielleicht?

Dadurch würde jedenfalls erklärt, warum ich das Problem auf dem WinXP nicht hatte, das Zertifikat immer gültig war, und ich nichts manuell updaten musste.
Wenn auf dem neuen Rechner das Zertifikat unterschiedlich ist, ist klar, warum das per Thunderbird-Profil vom alten Rechner importierte nicht mehr passt.
Dann müsste es eigentlich auch reichen, im TB-Profil das ungültige Zertifikat zu löschen, und Avast oder Thunderbird sorgen bei der nächsten Anfrage automatisch wieder für ein gültiges Zertifikat. Auf dem früheren XP-Rechner muss das doch auch so ähnlich abgelaufen sein. :eek:

Elektro
03.06.13, 16:26
Hallo,
ich verwende den Thunderbird Portable und hatte an 2 verschiedenen PCs Windows 8 und Windows 7 kein Problem mit dem Importierten Zertifikat.
Den Thunderbird habe ich auf den USB Stick und kann an jeden Pc die Mails lesen ....

Geht es nicht nach der Anleitung?

Herzmann
03.06.13, 16:52
Geht es nicht nach der Anleitung?
Ich habe mich nun mal dran gesetzt :rolleyes:
Es scheitert schon ganz am Anfang, da auf meinem Win7 gar kein avast Zertifikat ist ...
1362

Elektro
03.06.13, 17:54
Hallo,
Bei Windows 8 konnte ich kein Zertifikat finden da habe ich eins vom Win 7 er PC verwendet

Herzmann
03.06.13, 17:59
1. Das avast! Mail Scanner Zertifikat wird aus dem Windows 7 certificate store wieder gelöscht, sobald man den avast! Mail-Schutz "anhält". Erst nach erneutem "Starten" steht es da wieder drin :cool:
2. Das vom XP-Rechner per Thunderbird-Profil importierte Zertifikat ist tatsächlich anders, als das, was vom avast! Mail-Schutz auf meinem Win7-Rechner bereitgestellte.
3. Es geht auch einfacher, wie ich schon vermutet hatte:
- avast! Mail-Schutz "Anhalten"
- Das ungültige avast! Mail Scanner Zertifikat aus dem Thunderbird-Profil löschen und TB wieder schließen.
- avast! Mail-Schutz "Starten"
- TB wieder starten
- Nun alle Zertifikatsanfragen bestätigen
- Jetzt sollte alles gehen, das Ergebnis sieht aber leicht verschieden aus:
(statt eines generellen Zertifikats gibt es nun für jeden E-Mail-Server ein eigenes Zertifikat)
1363

Elektro
03.06.13, 18:20
In meiner Antwort auf das Verlinkte Thema hatte ich dem Fragesteller doch geschrieben

Unter Server ( wie bei dir) darf kein Avast Eintrag mehr sein. Dort sind alle Avast Einträge zu Löschen.

Unter Zertifizierungsstellen sollte das neue Zertifikat liegen.

Bei mir ist beim Importieren eine Meldung gekommen das, das Zertifikat schon vorhanden ist.
Ich habe es Gelöscht und das neue dann unter Zertifizierungsstellen Importiert.

Elektro
03.06.13, 18:50
Hallo,
wenn das bei dir jetzt geht, OK.
Ich hatte mit den einzeln Zertifikaten unter Server Probleme. Das ging mal und dann wieder nicht.

Herzmann
03.06.13, 19:57
Hi, ich habe jetzt dann doch mal die komplette Anleitung durchgespielt. Scheint auf die Dauer doch praktischer zu sein, vor allem, wenn neue Mail-Konten dazukommen.
AN AVAST:
1. Die Anleitung könnte so verbessert werden:
Unter "Exporting the Mail Shield certificate" sollte der Hinweis stehen, dass vorher der avast! Mail-Schutz gestartet sein muß, sonst gibt's da keine Zertifikate zu exportieren.
2. Wenn Thunderbird schon installiert und eingerichtet ist, scheint der avast!-Installer das Zertifikat automatisch in die Mozilla Profile zu importieren.
Wird Thunderbird aber erst nach der avast!-Installation eingerichtet, sollte avast! eine Funktionalität bereitstellen, das Zertifikat nachträglich in Thunderbird zu importieren.

Thunderbird sollte bei fehlendem/falschem Zertifikat auf keinen Fall den IMAP-Offline-Cache löschen und außerdem den nachträglichen Import bzw. ein Update aus dem Windows Certificate Store anbieten, siehe Bug 878764 (https://bugzilla.mozilla.org/show_bug.cgi?id=878764).

Mir Hilfe von Elektro konnte ich feststellen, dass die Zertifikate, wie weiter oben schon vermutet, auf unterschiedlichen Rechnern verschieden sind. Es macht also wohl keinen Sinn, in der Anleitung das Zertifikat als Anhang zum Download anzubieten.

Jetzt wäre nur noch zu klären, warum Elektro auf 2 verschidenen Installationen, Win7 - Win8, dasselbe Zertifikat verwenden konnte. Wurde das Win8 evtl. als Upgrade von Win7 installiert? Vielleicht werden die Zertifikate auch identisch generiert, wenn es sich um die gleiche Hardware handelt.

Elektro
03.06.13, 21:43
Hallo, habe das jetzt noch mal getestet.
Es geht auf den anderen PCs doch nicht.
Hatte das beim letzten Test wohl übersehen. Da waren wohl noch neue Mails im Thunderbird vom anderen PC vorhanden.
Da ich innerhalb von 3 Minute den Stick umgesteckt habe ist das nicht aufgefallen.

Jetzt habe ich wieder ein Problem mit Thunderbird Portable auf verschiedenen PCs
Lösung in Sicht?

Herzmann
03.06.13, 22:23
Jetzt habe ich wieder ein Problem mit Thunderbird Portable auf verschiedenen PCs
Lösung in Sicht?
Vielleicht hilft es ja in dem Fall, das von mir beschriebene Verfahren mit den einzelnen Schlüsseln der Mail-Server zu verwenden, die sind vielleicht "portable".

Elektro
03.06.13, 22:31
Hallo Herzmann,
damit hatte ich ja schon mal viel Probleme, dann werde ich an anderen PCs selber den Mailschutz abschalten.
bzw. im anderen Forum Nachfragen

Merlin
03.06.13, 23:47
Hallo,

Thunderbird hat ja einen eigenen Keystore und in den muss das Zertifikat rein.

Elektro
03.06.13, 23:57
Hallo Adama, Keystore was ist das?
Ein Zertifikat habe ich ja im Browser, nur geht dieses nicht am anderen PC

Merlin
04.06.13, 18:39
Hallo,

der Keystore enthält die Zertifikate. Thunderbird greift nicht auf den von Windows zurück, sondern nutzt seinen eigenen. avast! fügt beim Start des Mail-Schutz das Zertifikat automatisch in Windows und in Thunderbird ein, nur nicht bei portablen Versionen, da hier einfach die Pfade zur Konfiguration anders sind. Daher muss man es manuell machen, was allerdings dann nicht mehr funktioniert, wenn man an einem anderen Rechner damit arbeiten will. Dafür gibt es auch keinen Workaround. Dir bleibt nichts anderes übrig, als dort den Mail-Schutz einfach zu deaktivieren oder dort auch Thunderbird zu installieren.

Elektro
04.06.13, 19:48
Danke Adama, von meiner Seite kann das Thema geschlossen werden.

Herzmann
05.06.13, 01:36
Danke Adama, das hast Du wunderbar prägnant erklärt. :)
Ein Fall bleibt aber noch offen, nämlich wenn Thunderbird oder was für ein Programm auch immer auf einem System installiert/eingerichtet wird, wo avast! schon fertig installiert ist, und was m. E. auch die richtige Reihenfolge ist. In dem Fall stimmt die Aussage "avast! fügt beim Start des Mail-Schutz das Zertifikat automatisch ... in Thunderbird ein" nicht.

Der Thread-Titel müsste also jetzt richtigerweise lauten:
Mail-Schutz korrumpiert/blockiert nachträglich eingerichteten Thunderbird, was zur Löschung des Thunderbird IMAP-Offline-Store's führt.
avast! müsste nicht nur zum Zeitpunkt der Installation, sondern auch später, auf jeden Fall aber beim manuellen Starten des Mail-Schutz, mindestens vor dem Problem mit Thunderbird warnen, oder noch besser, gesteuert über einen vom User quittierten Dialog, dann nachträglich sein eigenes Zertifikat in Thunderbird einfügen, um dessen Funktion zu gewährleisten.
Mit ein bisschen Zusatzaufwand müsste das sogar für den Thunderbird portable machbar sein.
Dass, wenn das nicht erfolgt, der IMAP-Offline-Store von Thunderbird gelöscht wird, ist wahrscheinlich ein Fehler von Thunderbird.

Merlin
05.06.13, 15:48
Hallo,

es gibt sicher Situationen, in denen das Zertifikat nicht automatisch eingefügt wird, allerdings funktioniert es auch in vielen Fällen.

Der Mail-Schutz "korrumpiert" aber nichts, es wird weder "online" noch "offline" etwas gelöscht. Wahrscheinlicher ist, dass der Mail Client das Postfach nicht anzeigt, weil es Probleme bei der Verbindung zum Server gibt.

Herzmann
05.06.13, 23:15
Hm, also ich kenne bislang nur eine Situation, wo das Zertifikat von avast! automatisch eingefügt wird, und zwar, wenn avast! erst nach der Installation und dem Einrichten von Thunderbird installiert wird.

Hat jemand schon die Erfahrung gemacht, dass es auch bei umgekehrter Reihenfolge funktioniert, dann bitte mal melden.
Würde mich interessieren, warum das dann bei mir nicht funktionier(t|en) (hat|will).

Mit "korrumpieren" meine ich, dass durch die Aktivität des avast! Mail-Schutz die ganz normale Funktion des Thunderbird, nämlich E-Mails zu senden und zu empfangen, schlicht und ergreifend verhindert wird.
Das unerwünschte Löschen erfolgt nicht durch avast!, habe ich auch nie behauptet, sondern durch Thunderbird, der aus den verbleibenden oder auch vollständig blockierten Verbindungsinformationen den Schluss zieht, dass auf dem IMAP-Mail-Server alle Mails und Ordner gelöscht sind, und zwecks Synchronizität dann lokal auch alles löscht.
Die von Dir erwähnten "Probleme bei der Verbindung zum Server" waren in meinem Fall allein durch die Aktivität des Mail-Schutz bedingt. So bald ich den Mail-Schutz stoppte, lief alles normal, startete ich ihn wieder, war wieder alles blockiert.
Thunderbird zeigt das IMAP-Postfach entgegen Deiner Vermutung im Normalfall auch offline an, wenn, wie in meinem Fall, die IMAP-Mails und -Ordner zum Offline-Lesen vorher heruntergeladen wurden. Kann er sich aber einloggen, und kann mit den weiteren über den avast! Mail-Schutz Proxy empfangenen Daten mangels passendem Schlüssel nichts anfangen, und löscht er dann unglücklicherweise den kompletten vorhandenen Offline-Store, sodass beim nächsten normalen Offline-Lesen nichts mehr da ist.

Merlin
06.06.13, 21:22
Hallo,

den Offline-Store sollte er eigentlich nicht löschen, dafür gibt es keine Funktion in avast!. Die Schutzfunktion bezieht sich lediglich auf die Verbindung zum Mailserver.

Herzmann
06.06.13, 23:30
Hallo Abama,
schrieb ich doch. TB löscht den Offline-Store selber infolge des falschen/fehlenden avast! Zertifikats in dessen Profil.
Der Mangel auf avast!s Seite ist, dass bei erneutem Start des Mail-Schutz bzw. vor abermaliger Verschlüsselung der neu empfangenen und auf Viren überprüften E-Mails mittels des avast!-Zertifikats nicht erneut geprüft wird, ob in den betreffenden TB-Profilen das korrekte avast! Zertifikat vorhanden ist, mittels dem die durchgeschleusten E-Mails dort wieder entschlüsselt werden können.

Eine entsprechende Anfrage habe ich nun hier gepostet: http://forum.avast.com/index.php?topic=126530.msg949837#msg949837

Merlin
09.06.13, 16:16
Hallo,

dann gehen die Daten ja nicht verloren (sie sind ja noch auf dem Server), sondern TB löscht maximal den lokalen Cache der Daten. Das entspricht aber nicht einem Datenverlust.

Wie gesagt kann es sein, dass das Einfügen des Zertifikats nicht immer funktioniert, daher gibt es ja auch eine entsprechende Anleitung, wie man es manuell macht: http://www.avast.com/faq.php?article=AVKB91

Merlin
20.06.13, 14:41
Hallo,

da keine weitere Rückfrage mehr kam, schliesse ich das Thema als "Gelöst".