PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Geschlossen avast! 8 und VirtualBox



Rubix
05.03.13, 07:41
Hallo,

seit dem Update auf Avast 8 Free wird bei mir in VirtualBox Intel VT-x bzw. AMD-V deaktiviert. Dadurch starten keine 64-bit-Gäste mehr. Ich habe die VirtualBox.exe zu den Ausnahmen hinzugefügt und dann beim Verhaltens-Schutz die Überprüfung auf Low-Level Rootkits deaktiviert (da solche Rootkkits evtl. auch diese Virtualisierungsfunktionen nutzen würden). Nach einem Reboot funktionieren die Virtuellen Maschienen dann erstmal. Nach einem späteren Neustart ist VT-x aber wieder deaktiviert (ohne dass ich im BIOS-Setup oder in den VirtualBox-Einstellungen etwas geändert hätte). Die Anpassungen an den Avast-Einstellungen sind in der Benutzerschnittstelle noch eingetragen.

Hat jemand ähnliche Probleme mit der neuen Avast-Version? Wie kann man VirtualBox mit VT-x / AMD-V dauerhaft lauffähig halten?

Merlin
05.03.13, 13:03
Hallo,

bitte versuch mal das hier: http://forum.avadas.de/threads/5203-Seit-Update-Videos-im-Browser-fehlerhaft?p=45227&viewfull=1#post45227

Rubix
06.03.13, 07:47
Hallo,

habe ich gemacht. Nach einem späteren Neustart und sogar nach dem nächsten Reboot war VT-x/AMD-V deaktiviert. Der DLL-Austausch hat wohl nichts gebracht. Ich habe dann mit den Avast-Einstellungen rumgespielt und mehrmals neu gestartet. Jetzt geht es gerade. In den Avast-Einstellungen muß auf alle Fälle "Rootkit-Prüfung beim Systemstart aktivieren" deaktiviert werden, damit die Virtualisierung funktioniert.

The_Voice_70
06.03.13, 15:57
Hallo,

Hast du das ganze mal mit dem VM Player ausprobiert ? Ich habe mir mal den Vergleich Virtual Box sowie VM Player gegönnt . Im Endeffekt funktionierte der VM Player sehr viel problemloser so das ich dabei geblieben bin . Avast 8 läuft auf der virtuellen Maschine bestens im VM. Virtual Box gibt häufiger Fehlermeldungen in der Richtung aus ...

Rubix
07.03.13, 08:33
Hallo,

den VMWare Player hatte ich vor Jahren. Die Installation von VirtualBox am Wirt-Rechner war zumindest damals (bei meinem Umstieg) deutlich schlanker. Außerdem sind (waren?) die Möglichkeiten, neue Gäste zu erzeugen und zu konfigurieren, beim VMWare Player recht eingeschränkt. Und bis zur Installation von Avast 8 funktionierte auch VirtualBox problemlos.

Avast 8 läuft bei mir übrigens auf dem Wirt, die Clients laufen ohne eigene AV-Software (ich verwende überwiegen Linux-Clients in Virtuellen Maschinen).

Merlin
07.03.13, 12:43
Hallo,

es wird wahrscheinlich noch heute eine neue Version veröffentlicht, die das Problem beheben sollte.

Merlin
08.03.13, 17:16
Hallo,

Problem mit der neuen Version behoben? -> http://forum.avadas.de/threads/5262-avast!-8-0-1483

Merlin
14.03.13, 13:03
Hallo,

da keine weitere Rückmeldung mehr kam, schliesse ich das Thema. Wenn noch Bedarf besteht, bitte eine PN an die Moderatoren.