PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Gelöst Probleme beim Zugriff auf USB-Stick



dimi.s
26.06.12, 14:49
Hallo,

ich benutze Avast Free seit gute 3-4 Jahren und bin sehr zufrieden damit.
Zum Dateienverwaltung benutze ich Total Commander (Gewönnung seit DOS-Zeiten - Norton Commander und Dos Navigator :) )
Aber seit ca. 2 Wochen habe ich ein Problem. Wenn ich auf USB-Stick zugreife, wo große Dateien gespeichert sind (>500mb)
kann ich ca. 10-60 Sekunden nichts machen da, wie es aussieht, Avast diese Dateien auf Viren scannt.
Wenn ich Avast für 1 Stunde deaktiviere, passiert sowas nicht.
Wie kann ich diese Funktion deaktivieren?

p.S. Habe Windows 7 64 bit mit SP1 und letze stabile Version von Avast 7.0

MfG

Zycho
26.06.12, 14:57
Man kann dieses Verhalten unterbinden, in dem man den Laufwerksbuchstabe in die Ausnahmeliste des Dateisystem-Schutzes hinzufügt.
ABER VORSICHT: Sollte der Laufwerksbuchstabe nicht fix sein, also sich immer wieder ändern, kann es sein, dass bei mehreren angeschlossen Geräten ein anderes Gerät gescannt wird.

Beispiel: USB-Stick trägt den Laufwerksbuchstabe E:

E:\*.*

so bitte eintragen.

Zum Phänomen selbst: Da die auf dem USB-Stick befindlichen Dateien 500 MB und größer sind, dauert es dementsprechend bis avast! diese komplett ausgelesen und analysiert hat. Ich habe meine optischen Laufwerke ebenfalls auf der Ausnahmeliste, damit diese nicht ständig unnötig gescannt werden von avast!, weil ich weiß, dass nichts schädliches darauf ist, das spart Zeit und Nerven. ;)

Merlin
26.06.12, 15:41
Hallo,

ich würde hier eher nicht mit Ausnahmen arbeiten, da doch Gefahren von Daten auf USB Sticks ausgehen.

Was befinden sich denn für Daten auf dem USB Stick, d.h. welche Art von Dateien?

dimi.s
26.06.12, 17:23
Was befinden sich denn für Daten auf dem USB Stick, d.h. welche Art von Dateien?

Ich habe auf der arbeit eine neue Quartus-Version von Altera gezogen (ca. 2.5Gb groß), habe halt eine lahme Internetverbindung daheim. Zuhause den Stick eingesteckt und gute eine Minute gewartet bis ich Zugriff hatte.

Was mir direkt aufgefallen ist, früher hatte ich sowas nicht. Es ging immer richtig flott. Nur seit ca. 2 Wochen dieses Phänomen.

Kann man es so konfigurieren, das die Dateien NUR bei Ausführung überprüft werden, aber nicht bei auflisten oder kopieren??


Man kann dieses Verhalten unterbinden, in dem man den Laufwerksbuchstabe in die Ausnahmeliste des Dateisystem-Schutzes hinzufügt.

Wenn die Dateien beim Start trotzdem überprüft werden, dann reicht es mir. Es dürfen welche Viren ruhig auf dem Stick sich befinden, solange diese nicht ausgeführt werden.

MfG

Merlin
26.06.12, 17:40
Hallo,

hast du etwas an den Einstellungen des Dateisystem-Schutz verändert?

dimi.s
26.06.12, 20:06
Hallo,

hast du etwas an den Einstellungen des Dateisystem-Schutz verändert?

Ja, ich habe es versucht. Aber ohne Erfolg. Habe dann alle Einstellungen wieder rückwirkend gemacht.

dimi.s
26.06.12, 20:23
Habe zu Ausnahmen "*.*" für lesen hinzugefügt.

Scheint zu klappen!

Zycho
26.06.12, 20:47
Ähm, ist dir eigentlich klar, was du gerade tust?
*.* <--- Solch ein Eintrag für das Lesen bewirkt, dass gar nichts mehr beim Lesen gescannt wird. Unbedingt Laufwerksbuchstabe davor setzen!

Merlin
26.06.12, 21:44
Hallo,

bitte beides nicht so machen. Die Dateien auf dem USB Stick sollten sowohl beim Lesen als auch beim Ausführen geprüft werden. Versuche mal in den Einstellungen des Dateisystem-Schutz unter dem Reiter "Beim Anschließen prüfen" die Option "Autostart-Objekte beim Anschließen des Wechseldatenträgers prüfen" zu deaktivieren und schau mal, ob es dann besser wird.

Des weiteren könntest du das neue Pre-release testen: http://forum.avadas.de/threads/4496-avast!-7-0-1447-Release-Candidate

dimi.s
26.06.12, 21:47
Ähm, ist dir eigentlich klar, was du gerade tust?

Ja, mir ist klar, was ich tue.

Für mich heisst das, es werden ALLE Dateien beim Lesen nicht auf Viren geprüft.
Was, wenn ich richtig verstehe, nicht schlimm ist.
Beim Ausführen werden die Dateien trotzdem überprüft.
Infizierte Software, solange diese nicht ausgeführt wird, macht nichts schlimmes in meinem PC.

MfG

Merlin
26.06.12, 21:52
Hallo,

also ist das Problem jetzt für dich gelöst?

dimi.s
26.06.12, 21:55
Hallo,

bitte beides nicht so machen. Die Dateien auf dem USB Stick sollten sowohl beim Lesen als auch beim Ausführen geprüft werden. Versuche mal in den Einstellungen des Dateisystem-Schutz unter dem Reiter "Beim Anschließen prüfen" die Option "Autostart-Objekte beim Anschließen des Wechseldatenträgers prüfen" zu deaktivieren und schau mal, ob es dann besser wird.

Des weiteren könntest du das neue Pre-release testen: http://forum.avadas.de/threads/4496-avast!-7-0-1447-Release-Candidate (http://forum.avadas.de/threads/4496-avast%21-7-0-1447-Release-Candidate)

Habe schon beides ausprobiert.
Gerade läuft bei mir Avast v.7.0.1447 und Abwählen der Option "Autostart-Objekte beim Anschließen des Wechseldatenträgers prüfen" hat auch nichts gebracht.
Mit "*.*" habe ich leider auch kein Erfolg. Wie es aussieht, wenn die Dateien auf meinem USB-Stick einmal gescannt werden, merkt Avast diese und die werden beim nächsten mal nicht mehr überprüft. Anderen Stick rein und wieder das selbe Problem... warten!
Es passiert nicht nur mit USB-Sticks sondern auch mit Dateien auf der Festplatte, was aber nur ein Paar Sekunden dauert was mich nicht stört.

Vielleicht gibt es andere Wege dies zu deaktivieren?

MfG

Merlin
26.06.12, 22:30
Hallo,

hast du vielleicht noch irgendwelche anderen Sicherheitsprodukte installiert und sind die Treiber für die USB Schnittstelle auf dem aktuellen Stand?

dimi.s
26.06.12, 22:45
Ich habe noch Comodo Firewall Free auch drauf. Avast AV und Comodo FW laufen bei mir schon seit Jahren zusammen.

Genau das selbe Problem habe ich auch auf meinem Zweitrechner mit Win7 SP1 32 bit (frisch installiert).

TerraX
27.06.12, 02:24
Hallo,

jatzt hab ich das mal getestet...
Ich habe eine 1,5 Terra Festplatte, auf der sind min. 500 GB belegt, kann nach kürzester Zeit darauf zugreifen.
Kann mir aber jetzt nicht vorstellen, das an der Firewall liegen sollte.;)
Hast du zufällig in avast! unter Dateisystemschutz "Alle Dateien prüfen" angewählt.
Ansonsten kann ich mir die Problematik nicht vorstellen.:confused:

Merlin
27.06.12, 15:34
Hallo,

ich kann es auch nicht reproduzieren, daher liegt der Verdacht nahe, dass ein anderes Programm hier noch reinspielt. avast! greift zwar recht tief ins System ein, allerdings nur an die Schnittstellen, die Windows bietet. Daher sollte der Zugriff eigentlich normal ablaufen. Vielleicht hilft es zu schauen, welche Gemeinsamkeiten die beiden Rechner haben.

dimi.s
28.06.12, 17:56
Hallo,

habe gestern abend ausprobiert...
Windows 7 Home Edition 32 bit mit ServicePack1, frisch installiert.
Keine Updates, kein Internetverbindung.
Direkt Avast 7 Free installiert und direkt habe ich das Problem wieder.
Jetzt habe ich aber gemerkt:
1. Dieses Problem gibt es nur mit große .exe-Dateien, ISO's und Archive sind nicht betroffen.
2. Es hat mit USB eigentlich nichts zu tun. Auch auf der Festplatte werden diese Dateien auf Viren geprüft.
3. Es "bremst" nur im Total Commander, im Windows Explorer alles i.O.
4. Früher gab dieses Problem mit Total Commander nicht. Nur seit ein Paar Wochen.
5. Im Total Commander Configuration->Options->Icons->"All Associated + EXE/LNK" auf "All Associated" geändert. Damit ist das Problem behoben. Aber es werden keine Icons bei .exe-Dateien mehr angezeigt.

Fazit:
Total Commander beim Dateiauflisten greift auf .exe-Dateien um die Icon-Information rauszuholen. Avast prüft diese Datei auf Viren.
Wie gesagt, früher ging das sehr schnell, jetzt nicht mehr.

Das heisst, es ist an der neue Avast-Version etwas wirklich "neu" :)
Also, ich lasse es zurzeit so, ohne Icons.

MfG

dimi.s
28.06.12, 21:32
Habe noch andere Probleme mit neuem Avast entdeckt...
z.B. MSYS bei MinGW wird nicht mehr ausgeführt. Ich starte "msys.bat" und im Taskmanager wird der Prozess "cmd.exe" immer wieder gestartet. Nach 5 minuten über 3000 mal bis mein Win7 eingefrohren hat. Avast deaktivieren und alles geht wieder!
Habe im Inet Avast 6.0.1000 gezogen und installiert. Wieder glücklich. Ich bleibe erst mal bei alte Version.

p.S. alles mit Standarteinstellungen getestet. Und ohne zusätzliche Software mit frisch installiertem Win7.

MfG

Merlin
28.06.12, 22:14
Hallo,

versuch es doch mal mit dem heute erschienenen Update avast! 7.0.1451: http://forum.avadas.de/threads/4548-avast!-7-0-1451

Bei MSYS kannst du mal versuchen die AutoSandbox zu deaktivieren.

dimi.s
01.07.12, 18:05
Man kann dieses Thema als "gelöst" markieren. Habe die Ursache gefunden.
Bei "Dateisystemschutz"->"Archive" habe ich alle Archiv-Formate deaktiviert.
Nun tickt es wieder wie gewollt.

Danke an alle!

MfG

TerraX
01.07.12, 18:34
Hallo,

danke für die Rückmeldung, schliesse dann als "Gelöst".