PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Gelöst avast4workstation_1.3.0-2_i386.deb: Nach der Installation Probleme beim Update



pCfjuDvF
11.03.12, 22:30
Hallo,

ich habe die Installation von avast4workstation_1.3.0-2_i386.deb mittels GDebi-Paket-Installationsprogramm unter Knoppix 7.0 (Debian) durchgeführt.

Die Installation klappt, Avast lässt sich starten. Nach dem ersten Update tritt jedoch beim Starten des Programms nachfolgender Fehler auf:

Avast! Error
An error occured in avast! Engine: Das Argument ist ungültig.
OK Details

20:48:38: Deleted stale lock file '/home/knoppix/.avast/lockfile-knoppix'.
20:48:41: An error occured in avast! engine: Das Argument ist ungültig

Vielen Dank für Eure Hilfe.

Merlin
11.03.12, 22:34
Hallo,

bitte mal hier schauen: http://forum.avadas.de/threads/1691-avast!-for-Linux-Fehlermeldung-quot-invalid-argument-quot

pCfjuDvF
12.03.12, 17:52
Herzlichen Dank !!!!

sudo sysctl -w kernel.shmmax=100000000 funktioniert.

Folgende Zeile in die Datei /etc/sysctl.conf einfügen, funktioniert nicht:

Code:

kernel.shmmax=100000000

Besitzer von sysctl.conf ist root. Wie muss ich vorgehen, wenn ich die Rechte ändern möchte.

Merlin
12.03.12, 21:06
Hallo,

du musst den Editor, mit dem du die Datei bearbeitet, auch von einem Terminal mit "sudo" davor aufrufen, so hat die Anwendung auch root-Rechte. Ansonsten bleibt die Änderung nicht aktiv und ist beim nächsten Neustart weg.

pCfjuDvF
13.03.12, 18:02
Hallo,

ich habe kernel.shmmax=100000000 in die Datei sysctl.conf eintragen, aber Avast startet trotzdem nicht. Stattdessen erscheint folgende Fehlermeldung auf dem Bildschirm:

"Avast! Error
An error occured in avast! Engine: Das Argument ist ungültig"


Nach Starten von sudo leafpad treten beim Öffnen von KNOPPIX-DATA/etc/sysctl.conf nachfolgende Fehlermeldungen auf:

knoppix@Microknoppix:~$ sudo leafpad

(leafpad:3141): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Datei »/root/.local/share/recently-used.xbel.BV4SAW« konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden

(leafpad:3141): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: Datei oder Verzeichnis nicht gefunden

(leafpad:3141): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Datei »/root/.local/share/recently-used.xbel.673SAW« konnte nicht angelegt werden: Datei oder Verzeichnis nicht gefunden

(leafpad:3141): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: Datei oder Verzeichnis nicht gefunden

Was mache ich falsch? Warum bleibt der Eintrag kernel.shmmax=100000000 in der sysctl.conf ohne Wirkung?

Inhalt der Datei sysctl.conf:

kernel.shmmax=100000000

#
# /etc/sysctl.conf - Configuration file for setting system variables
# See /etc/sysctl.d/ for additonal system variables
# See sysctl.conf (5) for information.
#
#kernel.domainname = example.com

# Uncomment the following to stop low-level messages on console
#kernel.printk = 3 4 1 3

################################################## ############3
# Functions previously found in netbase
#
# Uncomment the next two lines to enable Spoof protection (reverse-path filter)
# Turn on Source Address Verification in all interfaces to
# prevent some spoofing attacks
#net.ipv4.conf.default.rp_filter=1
#net.ipv4.conf.all.rp_filter=1

# Uncomment the next line to enable TCP/IP SYN cookies
# See http://lwn.net/Articles/277146/
# Note: This may impact IPv6 TCP sessions too
#net.ipv4.tcp_syncookies=1

# Uncomment the next line to enable packet forwarding for IPv4
#net.ipv4.ip_forward=1

# Uncomment the next line to enable packet forwarding for IPv6
# Enabling this option disables Stateless Address Autoconfiguration
# based on Router Advertisements for this host
#net.ipv6.conf.all.forwarding=1

################################################## #################
# Additional settings - these settings can improve the network
# security of the host and prevent against some network attacks
# including spoofing attacks and man in the middle attacks through
# redirection. Some network environments, however, require that these
# settings are disabled so review and enable them as needed.
#
# Do not accept ICMP redirects (prevent MITM attacks)
#net.ipv4.conf.all.accept_redirects = 0
#net.ipv6.conf.all.accept_redirects = 0
# _or_
# Accept ICMP redirects only for gateways listed in our default
# gateway list (enabled by default)
# net.ipv4.conf.all.secure_redirects = 1
#
# Do not send ICMP redirects (we are not a router)
#net.ipv4.conf.all.send_redirects = 0
#
# Do not accept IP source route packets (we are not a router)
#net.ipv4.conf.all.accept_source_route = 0
#net.ipv6.conf.all.accept_source_route = 0
#
# Log Martian Packets
#net.ipv4.conf.all.log_martians = 1
#

Merlin
13.03.12, 18:33
Hallo,

hast du, nachdem du den Eintrag vorgenommen hast, den Rechner neu gestartet?

pCfjuDvF
13.03.12, 21:15
Ja, mehrmals ausprobiert.

Merlin
13.03.12, 22:17
Hallo,


eigentlich sollte die Zeile am Ende der sysctl.conf eingefügt werden, was aber hier auch nicht das Problem sein dürfte. Alternativ kannst du



kernel.shmmax=100000000


aber auch versuchen, den Befehl



echo 128000000 >/proc/sys/kernel/shmmax


am Ende der Datei /etc/rc.d/rc.local einzufügen. Das sollte eigentlich einen ähnlichen Effekt haben, wird nur später geladen.

pCfjuDvF
14.03.12, 17:37
Hallo,

eine Datei rc.local im Verzeichnis /etc/rc.d gibt es auf meiner Installation nicht. Eine Suche nach der Datei rc.local ergibt:

/UNIONFS/var/lib/update-rc.d/rc.local
/UNIONFS/etc/init.d/rc.local
/UNIONFS/etc/rc2.d/S99rc.local
/UNIONFS/etc/rc3.d/S99rc.local
/UNIONFS/etc/rc5.d/S99rc.local
/UNIONFS/etc/rc.local
/UNIONFS/etc/rc4.d/S99rc.local
/KNOPPIX/etc/init.d/rc.local
/KNOPPIX/etc/rc.local
/KNOPPIX/etc/rc2.d/S99rc.local
/KNOPPIX/etc/rc3.d/S99rc.local
/KNOPPIX/etc/rc4.d/S99rc.local
/KNOPPIX/etc/rc5.d/S99rc.local
/KNOPPIX/var/lib/update-rc.d/rc.local

Anlegen von /KNOPPIX-DATA/etc/rc.d/rc.local mit Inhalt echo 128000000 >/proc/sys/kernel/shmmax bringt nichts.

/KNOPPIX/etc/rc.local: Die Datei kann nicht zum Schreiben geöffnet werden (Obwohl das Verzeichnis als Root geöffnet wurde.)

Welche rc.local ist jetzt die Richtige?

Nachtrag: Ich benutze Knoppix 7.0 auf USB-Stick mit verschlüsseltem Datenbereich (knoppix-data.aes; wird eingebunden als /KNOPPIX-DATA).

Merlin
14.03.12, 19:10
Hallo,

eine von denen müsste es sein:



/KNOPPIX/etc/rc.local
/UNIONFS/etc/rc.local


Im Zweifelsfall mal bei beiden einfügen. Überprüf auch mal, ob nach dem Neustart die Datei noch in dem von dir veränderten Zustand da ist.

pCfjuDvF
15.03.12, 17:34
Hallo,

für die Hilfe, die ich hier erhalten habe, möchte ich mich herzlich bedanken.

Ich habe den Inhalt von /UNIONFS/etc./rc.local (Datei wird auch abgelegt in /KNOPPIX-DATA/etc/rc.local) geändert und die Zeile echo 128000000 >/proc/sys/kernel/shmmax hinzugefügt:

#!/bin/bash
#
# rc.local
#
# Start local services after hardware detection

SERVICES="cups"

for i in $SERVICES; do
[ -x /etc/init.d/"$i" ] && /etc/init.d/"$i" start >/dev/null 2>&1
done

echo 128000000 >/proc/sys/kernel/shmmax

exit 0

Nun startet Avast nach dem Neustart. Die Datei rc.local ist nach dem Neustart unverändert.

Merlin
15.03.12, 18:39
Hallo,

danke für die Rückmeldung, dann schliesse ich das Thema als "Gelöst".