PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Geschlossen Avast für BSoD verantwortlich (?)



haggys22
16.04.11, 16:35
Hallo,
ich habe gerade mein System neu aufgesetzt, und das erste Mal Avast als AV-Software installiert, nachdem ich früher immer AntiVir verwendet habe.
Doch seit eben genau dieser Umstellung habe ich beim Hochfahren immer folgendes Problem: Ich starte den PC, und während das OS (Win7 x64 Ultimate) lädt, kommt es zu einem BlueScreen. Nach einem Reset lädt das System, jedoch wird anstelle des Anmeldebildschirms nur ein schwarzer Screen und der Mauszeiger angezeigt, ich kann mich jedoch auch nicht "blind" anmelden. Erst beim dritten Versuch funktioniert es immer.
Meine Vermutung, dass das Problem durch Avast hervorgerufen wird lässt sich damit begründen, dass der Fehler vor der Installation von Avast, und nach einstweiliger Deinstallation nicht mehr aufgetreten ist.
Auch während des Betriebs schien mir Avast einen BSoD hervorzurufen. Ich habe meinen PC mit Avast auf (hoffentlich nicht vorhandene) Viren überprüfen lassen wollen, jedoch kam ca. 5 Sekunden nach dem Start ein BlueScreen. Viren sollten aber nicht auf dem System sein, da ich noch kaum etwas auf dem PC gemacht habe, außer vertrauenswürdige Software zu installieren.

Ich hoffe auf baldige Rückmeldung,
haggys22

Auggie
16.04.11, 16:50
Mache bitte ein HIJackThis-Log und hänge es an einen Beitrag von Dir.
Zusätzlich schaue mal in die Ereignisanzeige von Windows nach Fehlern zur fraglichen Zeit.
Und last but not least, bei einem BSoD schreibt Windows ein sogen. Speicherabbild auf die Platte (Endung dmp), suche das bitte und poste den Inhalt hier ebenso.
Auslesen lässt sich das File mit diesem Tool: http://support.microsoft.com/kb/315263/de oder alternativ auch mit diesem Tool: http://www.nirsoft.net/utils/blue_screen_view.html

haggys22
16.04.11, 17:20
Mein HijackThis Log:


Logfile of Trend Micro HijackThis v2.0.4
Scan saved at 15:55:55, on 16.04.2011
Platform: Windows 7 (WinNT 6.00.3504)
MSIE: Internet Explorer v8.00 (8.00.7600.16766)
Boot mode: Normal

Running processes:
C:\Program Files (x86)\Windows Live\Messenger\msnmsgr.exe
C:\Program Files (x86)\Electronic Arts\EADM\EADMUI.exe
C:\Program Files (x86)\OpenOffice.org 3\program\soffice.exe
C:\Program Files (x86)\Renesas Electronics\USB 3.0 Host Controller Driver\Application\nusb3mon.exe
C:\Program Files\AVAST Software\Avast\AvastUI.exe
C:\Program Files (x86)\LogMeIn Hamachi\hamachi-2-ui.exe
C:\Program Files (x86)\OpenOffice.org 3\program\soffice.bin
C:\Program Files (x86)\Common Files\Java\Java Update\jusched.exe
C:\Program Files (x86)\ROCCAT\Kone[+] Mouse\Kone[+]Monitor.exe
C:\Program Files (x86)\Electronic Arts\EADM\EADM.exe
C:\PROGRA~2\ELECTR~1\EADM\EACoreServer.exe
C:\Program Files (x86)\Windows Live\Contacts\wlcomm.exe
C:\Program Files (x86)\Mozilla Firefox\firefox.exe
C:\Program Files (x86)\Mozilla Firefox\plugin-container.exe
C:\Program Files (x86)\Mozilla Firefox\plugin-container.exe
C:\Program Files (x86)\Common Files\Java\Java Update\jucheck.exe
C:\Program Files (x86)\Skype\Phone\Skype.exe
C:\Program Files (x86)\Skype\Plugin Manager\skypePM.exe
C:\Users\Haggi\Downloads\HiJackThis204.exe
C:\Windows\SysWOW64\DllHost.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = http://go.microsoft.com/fwlink/?LinkId=69157
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = http://go.microsoft.com/fwlink/?LinkId=69157
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Local Page = C:\Windows\SysWOW64\blank.htm
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =
F2 - REG:system.ini: UserInit=userinit.exe
O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files (x86)\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll
O2 - BHO: avast! WebRep - {8E5E2654-AD2D-48bf-AC2D-D17F00898D06} - C:\Program Files\AVAST Software\Avast\aswWebRepIE.dll
O2 - BHO: Windows Live ID-Anmelde-Hilfsprogramm - {9030D464-4C02-4ABF-8ECC-5164760863C6} - C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live\WindowsLiveLogin.dll
O2 - BHO: SkypeIEPluginBHO - {AE805869-2E5C-4ED4-8F7B-F1F7851A4497} - C:\Program Files (x86)\Skype\Toolbars\Internet Explorer\skypeieplugin.dll
O2 - BHO: Java(tm) Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files (x86)\Java\jre6\bin\jp2ssv.dll
O3 - Toolbar: avast! WebRep - {8E5E2654-AD2D-48bf-AC2D-D17F00898D06} - C:\Program Files\AVAST Software\Avast\aswWebRepIE.dll
O4 - HKLM\..\Run: [NUSB3MON] "C:\Program Files (x86)\Renesas Electronics\USB 3.0 Host Controller Driver\Application\nusb3mon.exe"
O4 - HKLM\..\Run: [avast] "C:\Program Files\AVAST Software\Avast\avastUI.exe" /nogui
O4 - HKLM\..\Run: [LogMeIn Hamachi Ui] "C:\Program Files (x86)\LogMeIn Hamachi\hamachi-2-ui.exe" --auto-start
O4 - HKLM\..\Run: [Adobe Reader Speed Launcher] "C:\Program Files (x86)\Adobe\Reader 9.0\Reader\Reader_sl.exe"
O4 - HKLM\..\Run: [Adobe ARM] "C:\Program Files (x86)\Common Files\Adobe\ARM\1.0\AdobeARM.exe"
O4 - HKLM\..\Run: [SunJavaUpdateSched] "C:\Program Files (x86)\Common Files\Java\Java Update\jusched.exe"
O4 - HKLM\..\Run: [RoccatKone+] "C:\Program Files (x86)\ROCCAT\Kone[+] Mouse\Kone[+]Monitor.EXE"
O4 - HKCU\..\Run: [Skype] "C:\Program Files (x86)\Skype\Phone\Skype.exe" /nosplash /minimized
O4 - HKCU\..\Run: [msnmsgr] "C:\Program Files (x86)\Windows Live\Messenger\msnmsgr.exe" /background
O4 - HKCU\..\Run: [EADM] "C:\Program Files (x86)\Electronic Arts\EADM\EADMUI.exe"
O4 - HKUS\S-1-5-19\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /autoRun (User 'LOKALER DIENST')
O4 - HKUS\S-1-5-19\..\RunOnce: [mctadmin] C:\Windows\System32\mctadmin.exe (User 'LOKALER DIENST')
O4 - HKUS\S-1-5-20\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /autoRun (User 'NETZWERKDIENST')
O4 - HKUS\S-1-5-20\..\RunOnce: [mctadmin] C:\Windows\System32\mctadmin.exe (User 'NETZWERKDIENST')
O4 - Startup: OpenOffice.org 3.3.lnk = C:\Program Files (x86)\OpenOffice.org 3\program\quickstart.exe
O9 - Extra button: Skype Plug-In - {898EA8C8-E7FF-479B-8935-AEC46303B9E5} - C:\Program Files (x86)\Skype\Toolbars\Internet Explorer\skypeieplugin.dll
O9 - Extra 'Tools' menuitem: Skype Plug-In - {898EA8C8-E7FF-479B-8935-AEC46303B9E5} - C:\Program Files (x86)\Skype\Toolbars\Internet Explorer\skypeieplugin.dll
O10 - Unknown file in Winsock LSP: c:\program files (x86)\common files\microsoft shared\windows live\wlidnsp.dll
O10 - Unknown file in Winsock LSP: c:\program files (x86)\common files\microsoft shared\windows live\wlidnsp.dll
O18 - Protocol: skype-ie-addon-data - {91774881-D725-4E58-B298-07617B9B86A8} - C:\Program Files (x86)\Skype\Toolbars\Internet Explorer\skypeieplugin.dll
O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - C:\PROGRA~2\COMMON~1\Skype\SKYPE4~1.DLL
O18 - Protocol: wlpg - {E43EF6CD-A37A-4A9B-9E6F-83F89B8E6324} - C:\Program Files (x86)\Windows Live\Photo Gallery\AlbumDownloadProtocolHandler.dll
O23 - Service: @%SystemRoot%\system32\Alg.exe,-112 (ALG) - Unknown owner - C:\Windows\System32\alg.exe (file missing)
O23 - Service: avast! Antivirus - AVAST Software - C:\Program Files\AVAST Software\Avast\AvastSvc.exe
O23 - Service: @%SystemRoot%\system32\efssvc.dll,-100 (EFS) - Unknown owner - C:\Windows\System32\lsass.exe (file missing)
O23 - Service: @%systemroot%\system32\fxsresm.dll,-118 (Fax) - Unknown owner - C:\Windows\system32\fxssvc.exe (file missing)
O23 - Service: LogMeIn Hamachi 2.0 Tunneling Engine (Hamachi2Svc) - LogMeIn Inc. - C:\Program Files (x86)\LogMeIn Hamachi\hamachi-2.exe
O23 - Service: @keyiso.dll,-100 (KeyIso) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @comres.dll,-2797 (MSDTC) - Unknown owner - C:\Windows\System32\msdtc.exe (file missing)
O23 - Service: @%SystemRoot%\System32\netlogon.dll,-102 (Netlogon) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: NVIDIA Driver Helper Service (NVSvc) - Unknown owner - C:\Windows\system32\nvvsvc.exe (file missing)
O23 - Service: PnkBstrA - Unknown owner - C:\Windows\system32\PnkBstrA.exe
O23 - Service: PnkBstrB - Unknown owner - C:\Windows\system32\PnkBstrB.exe
O23 - Service: @%systemroot%\system32\psbase.dll,-300 (ProtectedStorage) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: Remote Packet Capture Protocol v.0 (experimental) (rpcapd) - CACE Technologies, Inc. - C:\Program Files (x86)\WinPcap\rpcapd.exe
O23 - Service: @%systemroot%\system32\Locator.exe,-2 (RpcLocator) - Unknown owner - C:\Windows\system32\locator.exe (file missing)
O23 - Service: @%SystemRoot%\system32\samsrv.dll,-1 (SamSs) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @%SystemRoot%\system32\snmptrap.exe,-3 (SNMPTRAP) - Unknown owner - C:\Windows\System32\snmptrap.exe (file missing)
O23 - Service: @%systemroot%\system32\spoolsv.exe,-1 (Spooler) - Unknown owner - C:\Windows\System32\spoolsv.exe (file missing)
O23 - Service: @%SystemRoot%\system32\sppsvc.exe,-101 (sppsvc) - Unknown owner - C:\Windows\system32\sppsvc.exe (file missing)
O23 - Service: NVIDIA Stereoscopic 3D Driver Service (Stereo Service) - NVIDIA Corporation - C:\Program Files (x86)\NVIDIA Corporation\3D Vision\nvSCPAPISvr.exe
O23 - Service: @%SystemRoot%\system32\ui0detect.exe,-101 (UI0Detect) - Unknown owner - C:\Windows\system32\UI0Detect.exe (file missing)
O23 - Service: @%SystemRoot%\system32\vaultsvc.dll,-1003 (VaultSvc) - Unknown owner - C:\Windows\system32\lsass.exe (file missing)
O23 - Service: @%SystemRoot%\system32\vds.exe,-100 (vds) - Unknown owner - C:\Windows\System32\vds.exe (file missing)
O23 - Service: @%systemroot%\system32\vssvc.exe,-102 (VSS) - Unknown owner - C:\Windows\system32\vssvc.exe (file missing)
O23 - Service: @%systemroot%\system32\wbengine.exe,-104 (wbengine) - Unknown owner - C:\Windows\system32\wbengine.exe (file missing)
O23 - Service: @%Systemroot%\system32\wbem\wmiapsrv.exe,-110 (wmiApSrv) - Unknown owner - C:\Windows\system32\wbem\WmiApSrv.exe (file missing)
O23 - Service: @%PROGRAMFILES%\Windows Media Player\wmpnetwk.exe,-101 (WMPNetworkSvc) - Unknown owner - C:\Program Files (x86)\Windows Media Player\wmpnetwk.exe (file missing)

--
End of file - 8885 bytes
und die Infos aus der dmp Datei:


041611-25630-01.dmp 16.04.2011 15:16:43 SYSTEM_THREAD_EXCEPTION_NOT_HANDLED 0x1000007e ffffffff`c0000005 fffff800`02cb4b7f fffff880`033325c8 fffff880`03331e30 ntoskrnl.exe ntoskrnl.exe+95b7f NT Kernel & System Microsoft® Windows® Operating System Microsoft Corporation 6.1.7600.16695 (win7_gdr.101026-1503) x64 C:\Windows\Minidump\041611-25630-01.dmp 4 15 7600 282.448


Also des HijackThis Log ist sauber, jedenfalls laut der Auswertung, und auf des andre kann ich mir keinen Reim machen ;)

uweli1967
16.04.11, 18:18
haggys22, es könnte auch sein dass sich Avast mit einem Hardaretreiber deines Gerätes nicht verträgt. Wenn du möchtest kannst du mal damit: http://forum.avadas.de/threads/2165-DriverEasy nachschauen ob und welche anderen/neuen Treiber es für deine Hardware gäbe.

Auggie
16.04.11, 19:14
Das HJT-Log ist wirklich sauber, als Ansatzpunkt kommt für mich momentan nur der Capture-Treiber von WinPCap infrage.
Ist die aktuelle Version davon (4.1.2) installiert? Dieser Treiber arbeitet sehr tief im System und wird von einigen Tools, wie z.B. Whireshark oder WinDump zum Betrieb benötigt. Nicht immer ist die Version, die solche Tools mitinstallieren, die aktuellste Treiber-Version.
Aus dem Dump-File lässt sich, für mich, nicht wirklich etwas herauslesen, nur das ntoskrnl.exe beteiligt ist. Welche Treiber zum Zeitpunkt des BSoD geladen sind, lässt sich daraus leider nicht ersehen.
Ich glaube zwar auch nicht an eine Infektion, aber um das definitiv auszuschließen, würde ich mal eine Boottime-Prüfung des Systems machen.
Was sagt denn die Ereignisanzeige zum fraglichen Zeitpunkt?
Ausgelöst wurde der BSoD durch eine unbehandelte Ausnahme in der Datei ntoskrnl.exe, d.h. beim Laden eines Treibers ist es zu einem Fehler gekommen, der durch die angegebene Datei nicht abgefangen werden konnte. Wichtig wäre jetzt, zu erfahren, welcher Treiber das war.

haggys22
16.04.11, 19:24
@uweli1967:
ich habe den ersten Treiber heruntergeladen, und prompt kan eine Virenmeldung... soll ich den Treiber dennoch aktualisieren?

@Auggie
1.) WinPCap ist aktuell, da ich es mir erst vorgestern von der Homepage manuell heruntergeldane habe.
2.) Infektion ist so gut wie unmöglich, da ich nur wenige Programme installiert habe, und alle vertrauenswürdig sind.
- 7-Zip - Adobe Reader/Flash Player/Shockwave Player - ATI Catalist Install Manager - Avast - Battlefield Bad Company 2 - MSI Control Center - EA Download Manager - Java JDK - Hamachi - Firefox 4 - MSI Afterburner - NVIDIA 3D Vision Treiber/Grafiktreiber/PhysX - OpenOffice 3.3 - Realtek Ethernet Treiber/Audio Treiber - USB 3.0 Treiber - ROCCAT Kone[+] Treiber - Skype - Windows Live Essentials - WinPcap 4.1.2 - Starcraft II
3.) Wie meinen, "Ereignisanzeige"?

uweli1967
16.04.11, 20:05
ich habe den ersten Treiber heruntergeladen, und prompt kan eine Virenmeldung... soll ich den Treiber dennoch aktualisieren?
Nein, bevor du Treiber aktualisierst, würde ich erstmal eine Sicherung des Systems machen und den runtergeladenen Treiber der von Avast als Virus gemeldet wurde bei VirusTotal (http://www.virustotal.com/) hochladen und dort gegenprüfen lassen.

Merlin
16.04.11, 21:15
Hallo,

es könnte auch mit dem LogMeIn Hamachi Treiber zusammenhängen. Ist dieser aktuell?

haggys22
16.04.11, 21:20
Der Hamachi Treiber müsste auch aktuell sein, da ich alle Programme ja nicht früher als Donnerstag installiert habe. Also an alten Treibern und Programmen sollte es nicht liegen.

uweli1967
16.04.11, 21:29
Schau doch mal mit DriverEasy nach, ob das dir einen anderen Hamachi Treiber anbieten würde(noch nicht gleich installieren wenn dem so wäre).

Auggie
16.04.11, 23:01
Schau doch mal mit DriverEasy nach, ob das dir einen anderen Hamachi Treiber anbieten würde(noch nicht gleich installieren wenn dem so wäre).
Da nutzt Dir DriverEasy auch nix, weil das ein Programm ist und kein Hardware-Treiber.
Du kannst ja spaßeshalber mal versuchen, den avast!-FW-Treiber der IS damit zu aktualisieren.

Vor ein paar Tagen installiert heisst nicht automatisch, das alle Treiber und Programme auch aktuell sein müssen.
Um zu LogMeIn zurückzukommen: Wenn Du das Programm erst vor ein paar Tagen gekauft hast, kann man davon ausgehen, das es aktuell ist (und damit auch der Treiber), sonst würd ich einfach mal nach Updates schauen.

Merlin
17.04.11, 11:20
Hallo,

DriverEasy scheint meinem persönlichen Eindruck nach auch nicht so wirkungsvoll zu sein, Diskussion dazu aber bitte hier: http://forum.avadas.de/threads/2165-DriverEasy?p=26796&viewfull=1#post26796

haggys22: Kannst du den Minidump mal als ZIP Datei hier anhängen?

Auggie
17.04.11, 16:41
Ich wollte auch keine Diskussion über DriverEasy anzetteln, nur ist nicht alles, was sich Treiber nennt, auch ein Hardware-Treiber, die dieses Tool abdeckt.
Solche sogen. Nicht-Plug'n'Play-Treiber, die dieses LogMeIn (wie z.B. auch eine Desktop-FW) installiert, wird eben nicht von einem Tool abgedeckt, das sich auf Hardware spezialisiert hat.
Da würde man imho mit Secunia eher Glück haben.
Zurück zum eigentlichen Thema: Das von mir genannte BlueScreeView von Nirsoft unterschlägt leider die in diesem Fall wichtigen Informationen über die geladenen Treiber und Dienste (getestet mit einem eigenen Minidump).
Die liefern dagegen die MS Debugging-Tools aus dem ersten Link.
Der ein oder andere User hat die vielleicht installiert und kann die relevanten Infos dann aus dem angehängten Crashdump-File auslesen und hier posten.

haggys22
17.04.11, 21:30
So, hier sind die 4 Minidumps, in einem zip-Archiv... Ich werde davon zwar auch nicht schlauer, aber wenns euch hilft ;)

Merlin
18.04.11, 14:24
Hallo,

die Analyse der Crash Dumps liessen jetzt keinen direkten Rückschluss auf avast! zu, daher vermute ich, dass avast! vielleicht der Auslöser sein könnte (dadurch, dass es an vielen APIs von Windows ansetzt, um zu scannen), aber nicht das eigentliche Problem. Es sieht für mich eher danach aus, dass Systemdateien entweder beschädigt oder durch falsche Versionen ersetzt wurden. Daher würde ich zwei Dinge kontrollieren bzw. ausführen:

1) Prüfen, ob wirklich alle Windows Updates eingespielt sind. Zur Not nochmal das letzte Service Pack von Windows runterladen und drüber installieren.
2) Den Tipp aus diesem Forenbeitrag ausführen (um sicher zu gehen, dass es sich um gültige Dateien handelt): http://forum.avadas.de/threads/2283-Windows-SFC-(System-File-Checker)

Merlin
25.04.11, 10:36
Hallo,

da keine weitere Rückmeldung mehr kam, schliesse ich das Thema. Wenn noch Bedarf besteht, bitte eine PN an die Moderatoren.