PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Gelöst Komplette Daten aller Festplatten scanner?



Deichgraf
20.02.11, 16:42
Hallo zusammen,

ich habe mir auf meinem openSUSE11.3 Server avast4workstation installiert. Hat auch alles problemlos geklappt. Allerdings stelle ich mich wohl zu doof an, denn wenn ich mit dem Befehl:



DIONE:~ # avast -a -b -c -p=3 -t=A
Das Scanning auslöse, sagt er, das er nur:



#scanned Files: 8558
#Scanned directorys: 740
#infected files: 0
#total files scanned: 2.3 GB
...
...
gescannt hat. Nun habe ich aber ingesamt 3 Platten mit einer Gesamtkapazität von 2,25TB (!) im Server. Eine der TB Platten ist nahezu vollgeschrieben, aber es scheint so, als ob er nur die Systemplatte scannt. Warum scannt er nicht alles?

Was mach ich falsch? Stimmen die Parameter nicht? Oder ist das eine Versions restriction? :confused:

//Edith
Edith fragt gerade nach einen Handbuch für diese Version...?!

Danke & Gruß
Deichi

Merlin
21.02.11, 15:28
Hallo,

hast du mal versucht, den Mountpoint direkt hinter den Optionen anzugeben und zu schauen, ob er dann scannt?

Eine Hilfedatei gibt es nicht. Würde sich auch nicht lohnen für einen reinen Command-Line On-Demand Scanner. Die Optionen kannst du ja direkt über --help aufrufen.

Deichgraf
21.02.11, 20:51
Ja super Sache! Funktioniert!



DIONE:~ # avast -a -b -c -p=3 -t=A /mountpoint


Nur mal so als Gedankenanstoss: Schreibt das doch mal mit rein bei "--help" :p
Ich dachte die Option "scanne Block Device" bezieht sich auf alle eingebauten Platten.
Scheint aber nicht so zu sein, was meint er dann damit?

Merlin
21.02.11, 23:08
Nur mal so als Gedankenanstoss: Schreibt das doch mal mit rein bei "--help" :p
Ich dachte die Option "scanne Block Device" bezieht sich auf alle eingebauten Platten.
Scheint aber nicht so zu sein, was meint er dann damit?

Block Devices können u.a. auch Festplatten sein, wobei nicht bei jedem System gewährleistet werden kann, dass avast! diese als solche erkennt. In dem Fall muss der direkte Pfad zum Mountpoint genutzt werden. Das steht übrigens auch in der Hilfe:


Usage: avast [OPTION...] <areaname...>

Da dein Problem jetzt gelöst ist, schliesse ich das Thema entsprechend.