PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Pre-release avast! 5.1.863 BETA



Merlin
07.12.10, 09:11
Hallo,

avast! hat diese Nacht die avast! 5.1.863 BETA seiner Produkte für Endanwender zur Verfügung gestellt, d.h. avast! Free 5.1.863 BETA, avast! Pro 5.1.863 BETA und avast! Internet Security 5.1.863 BETA. Es handelt sich hierbei um eine Testversion, mit der der Hersteller die Funktionalität vor der Herausgabe über die Updatefunktion testen möchte. Da damit zu rechnen ist, dass weitere sogenannte Builds folgen werden, ist hier aber noch Vorsicht geboten. Die Verwendung geschieht auf eigene Gefahr!

Download:

Free: http://files.avast.com/files/beta/5.1.863/setup_av_free.exe
Pro: http://files.avast.com/files/beta/5.1.863/setup_av_pro.exe
Internet Security: http://files.avast.com/files/beta/5.1.863/setup_ais.exe


Änderungen in der avast! 5.1 BETA:

- Bootzeitscanner für 64-bit Betriebssysteme
- Verbersserungen beim Verhaltensschutz - mehr Sensoren und damit auch die Möglichkeit, genauer den Angreifer festzustellen
- Verbesserungen bei der Reinigung infizierter Objekte
- Verbesserungen des Anti-Rookit Moduls, welches jetzt in der Lage ist, mit den neusten TDL Varianten umzugehen
- Verbesserungen beim Web-Schutz (Stabilität und Leistung)
- Mail und Web-Schutz sind nicht mehr in einen separaten Windows Dienst ausgelagert, was zu Verbesserungen beim Start führt
- Internet Security: Neue Version des Antispam Moduls
- Neue Sound Pakete

Der Verhaltensschutz arbeitet immer noch passiv und berichtet nur die Angriffe an den Hersteller, um somit mehr Daten zu sammeln, die wiederum zur Entwicklung des finalen Moduls beitragen, welches im ersten Quartal 2010 erscheinen soll. Dies geschieht nur dann, wenn man die Option "An der avast! Gemeinschaft teilnehmen" aktiviert hat.

Änderungen in der avast! 5.1.807 BETA:

- Abstürze von Drittanbieter Programmen beim Start (z.B. ATI Catalyst)
- Defekte Sandbox
- andere Probleme mit dem Verhaltensschutz
- Defekte Firewall Abfragen
- Defekte Bildschirmschonereinstellungen
- Hohe CPU Auslastung durch AvastSvc.exe während dem Download von großen EXE Dateien
- Berichtsdatei des Verhaltensschutz
- Langsamer Start des avast! Dienstes auf den meisten Rechnern
- Netzwerk-Schutz startet nicht (und bleibt im Schutzstatus: Unbekannt)
- Netzwerk sperren Anzeigeproblem

Änderungen in der avast! 5.1.835 BETA:
- Bluescreen Problem der Internet Security Version behoben, wenn Opera deinstalliert wird
- Alle anderen Probleme, die bisher aus den vorherigen Builds bekannt waren

Änderungen in der avast! 5.1.849 BETA:
- Behebung des Problems mit Drittanbieteranwendungen, die vom Fehler 0xC0000005 (oder 0xC000007B) betroffen waren, während sie gestartet wurden
- Schleife im Registrierungsdialog
- Freezes während während eines Scans (bedingt durch den MBR Rookit Scanner) . Hier ist noch nicht sicher, ob das Problem wirklich behoben wurde.

Änderungen in der avast! 5.1.857 BETA:
- Hängendes System, nach Absturz des avast! Dienstes
- Zwischenzeitliche Starts im klassischen Windows Desgin, verbunden mit dem Fehlstart einiger Dienste
- Absturz des Registrierungs-Dialogs
- Stabilitätsprobleme des Verhaltensschutz-Moduls
- Hohe CPU Auslastung, wenn die Netzwerkverbindung getrennt wird

In der avast! 5.1.857 BETA wurde vom Hersteller vorübergehend ein erweitertes Logging des Webschutz-Moduls aktiviert, um Probleme damit in kommenden Versionen zu beheben. Dies kann allerdings zu erhöhten Latenzen während der Nutzung des Internets führen. Diese Einstellung wird wieder entfernt, sobald die aktuellen Probleme mit dem Webschutz behoben sind.

Änderungen in der avast! 5.1.861 BETA:

- Probleme mit dem Verhaltensschutz-Modul (üblicherweise auf 64-bit Betriebssystemen)
- HTTP Pipelining Unterstützung im Webschutz-Modul (besonders interessant für Opera Benutzer)
- Eine mögliche "Race condition" in der aswSP.sys, die zu einem "hängenden" System führen konnte
- Ein Problem mit dem Outlook Antispam Plugin
- Entfernung des Limits für die Anzahl von Seiten bei der URL Blockierung (avast! Internet Security)

Änderungen in der avast! 5.1.862 BETA:
- Modifiziertes Verhaltensschutz-Modul auf 64-bit Windows Systemen (löst einige von benutzern aufgedeckte Probleme)
- Behebt wahrscheinlich das Problem mit der Registrierung der avast! Firewall im Windows Sicherheitscenter (hierfür bitte mit dem Uninstall Tool neu installieren, bei einem Update von einer vorherigen BETA oder Vollversion wird das Problem NICHT behoben)

Auggie
08.12.10, 18:27
Ich habe, da ich gerade ein neues XP-Testsystem aufgesetzt habe, mir die aktuell verfügbare Beta (Suite) herunter geladen.
Was gleich positiv auffällt:
Gleich nach der Installation wird mir eine Startzeit-Prüfung des Systemlaufwerks angeboten.
So hat man gleich einen Status Quo, ob das System sauber ist.....das kenne ich aus früheren Zeiten schon (nur eben keine Startzeit-Überprüfung sondern vor der Installation wurde das Systemlaufwerk mit einem Quickscan auf mögliche Malware geprüft und bei einem positiven Befund die Installation verweigert).
Weitere Neuerung:
Die Einblendungsdauer der avast-PopUps (Update durchgeführt etc.) lässt sich jetzt einstellen.....wir hatten vor kurzem ja mal den Fall, das im Scanprotokoll ein Fund auftauchte, aber (angeblich) keine Meldung erschien. Die Standardeinstellung von 20 Sekunden finde ich hier völlig ausreichend.

Merlin
09.12.10, 09:37
Hallo,

gestern ist die BETA aktualisiert worden, die neue Versionsnummer lautet: avast! 5.1.803

Ich habe meine Ursprungspost entsprechend angepasst.

Auggie
09.12.10, 11:33
Das dir der rechner nicht auch "einfriert"
Das Problem ist einfach handlebar.....einfach das System neu aufsetzen bzw. das System auf den ersten Snapshot zurücksetzen (Zeitbedarf ca. 5-10 Minuten).
Da es ja kein Produktivsystem ist sondern eine virtuelle Maschine, ist dieser Punkt für mich nicht wirklich wichtig.
Um das Testsystem näher an die (meine) realen Bedingungen zu bringen, wird noch eine IDE, das Office-Paket sowie 2 Anwendungen zur Fotobearbeitung installiert....es wird also auch richtig ein wenig "gearbeitet" mit dem System.
Mal schauen, wie die Zusammenarbeit z.B. mit Firefox aussieht.....

Dem XP-Sicherheitscenter mußte ich übrigens deutlich machen, das es weder die FW noch das AV-Programm überwachen soll; das hatte bei mir auf dem Testsystem angezeigt, das kein AV-Programm installiert sei und die FW deaktiviert sei.....bei avast! selber war natürlich trotzdem alles im grünen Bereich.
Das altbekannte Problem mit dem Windows-Sicherheitscenter.
Werde die Überwachung jetzt mal wieder einschalten und testen, ob der in der FAQ hier genannte Weg das Problemchen auch lösen könnte, da war gestern keine Zeit mehr für.

Auggie
09.12.10, 16:54
Nach einem 3 Stunden Test, wo das System mit der IS gelaufen ist, kann ich eines zumindest sagen:
Bisher läuft die Version stabil, zumindest unter meinen Testbedingungen.
Da es eine neue Version gibt.....mal schauen, ob die Updatefunktion komplett funktioniert und ich die neuere Version aus der Oberfläche heraus bzw. dem Update installieren kann.

Update:
Die automatische Update-Funktion hat nur ein Signaturupdate durchgeführt, es erschien auch keine Meldung, das eine neue Programmversion vorläge; mag aber sein, das hier bewußt erst zu einem späteren Zeitpunkt nachgefragt worden wäre.....das hatten wir ja bei aktuellen, finalen Version schon mal angerissen, das ein Programmupdate recht spät erfolgten würde.
Manuell angestoßen hat das Programmupdate jedoch problemlos funktioniert.
Was mir jetzt nach dem Update auffiel: Der Systemstart im besonderen und der avast!-Start (bis alle Module vollständig laufen) lief spürbar schneller ab als vor dem Update. Ob sich das bewahrheitet, werde ich bei dem jetzt folgenden "Kaltstart" testen.....das dürfte in erster Linie für die User interessant sein, die nur wenig Arbeitsspeicher haben (das Testsystem läuft bewußt nur mit 512MB Ram).

Update 2:
Nach dem "Kaltstart" muß ich meinen Eindruck ein wenig relativieren:
Bis alle Module vollständig geladen sind, sind ca. 2 1/2 Minuten vergangen, meiner Ansicht nach war das bei der vorherigen Beta noch etwas langsamer.
Allerdings lag zu Beginn die Netzwerkverbindung noch nicht vollständig vor (Lan)....das ist zum Teil technisch durch die Virtualisierung bedingt, zum andern Teil hatten wir ja schon mal festgestellt, das avast! auf die Netzwerkverbindung wartet.
Da Zeit im privaten Bereich imho eine untergeordnete Rolle spielt, sind für mich auch 5 Minuten vertretbar, bis alles im grünen Bereich ist.

tiger64
09.12.10, 19:12
Mag seien das die zeit nicht so wichtig ist,aber wenn ich das mit meiner jetzigen
Startzeit vergleiche wäre es für mich doch erstmal gewöhnungsbedürftig!!
2 1/2 Min.,das geht bei mir jetzt doch wesentlich schneller!
Aber abwarten,es sind ja nur beta versionen die sicherlich auch da noch verbessert werden!

Auggie
09.12.10, 19:27
Lass mal die konkreten Zeitangaben beiseite; man kann diese Zeitangaben nicht mit denen auf einem stabil laufenden, physisch vorhandenen Produktivsystem vergleichen. Wenn man Zeitangaben vergleichen wollte, müßten die Bedingungen gleich sein; das geht bei einer virtuellen Maschine prinzipbedingt schon nicht im Vergleich mit einem physischen System.
Hinzu kommt, das es eben auch noch eine Beta-Version ist.
Wodurch die Zeiten zustande gekommen sind, habe ich ja versucht zu erklären.

gerd88
09.12.10, 20:21
Dein Test und wie du uns auf dem laufenden hälst ist schon sehr gut, so wird man doch schon gut informiert. Nutze zwar XP nicht mehr, aber die Ergebnisse sind ja auch für Win7 anzunehmen.

Merlin
10.12.10, 09:32
Hi,

ich überlege nur gerade, ob wir den Test nicht entweder an meine Meldung dranhängen unter "Ankündigungen" dran hängen (dort darf zwar kein Thema eröffnet werden, doch die Themen sind für Diskussionen offen) oder an die Meldung hier unter Smalltalk, wobei es in letzterem wahrscheinlich eher untergehen würde und das wäre schade.

gerd88
10.12.10, 11:56
Unter Ankündigungen wäre es gut, wichtig ist ja des es nicht untergeht.

Auggie
10.12.10, 13:56
Den Bericht an die Meldung zu hängen, ist schon sinnig, beides gehört ja auch irgendwie auch zusammen.
Ursprünglich hatte ich gar nicht vor, mich so intensiv mit der Beta zu beschäftigen, es passte halt gerade, da ich mein XP-System neu einrichten mußte.
Und wenn es nur ums Untergehen des Threads geht.....man kann den ja einfach "pinnen" für die Zeit bis zur Veröffentlichung der finalen Version.
Naja gerd, falls es spezifische XP-Probleme (oder analog dazu Probleme nur unter Win 7) wäre es schon sinniger, das entsprechende System zu haben. Aber sonst hast Du natürlich Recht, das sich die Erkenntnisse übertragen lassen.

gerd88
10.12.10, 14:00
So sehe ich das auch, naja wenn die Version da ist (nicht Beta) "testen" wir ja alle, dann sehe ich auch was/wie sie unter Win7 mit Outlook 2010 läuft. Das ist es was mich interessiert

Auggie
10.12.10, 14:14
Was Office 2010 angeht, macht es wohl nicht so einen großen Unterschied, ob unter XP oder Win 7 getestet wird.
Office 2010 ist zwar mehr auf Win 7 zugeschnitten, aber auf jeden Fall vollständig abwärtskompatibel auf XP SP3.
Office installiere ich als nächsten Schritt.

Merlin
10.12.10, 14:26
Hallo,

wieder eine Aktualisierung auf avast! 5.1.807 BETA. Links und Titel sind wieder angepasst, übersetzte Änderungen kommen später.

Auggie
10.12.10, 17:08
Direkt zu Adamas letzten Beitrag passend:
Nach Start des Systems und Updateanfrage wurden die Signaturen aktualisiert.
Der Start der Programmoberfläche machte mich dann direkt auf der Startseite auf die neue Programmversion aufmerksam, der eingeblendete Update-Button hat dann auch problemlos das Update durchgeführt.
Was mir aufgefallen ist: Obwohl ich das Update gleich wieder abgebrochen hatte (es lief gleichzeitig eine andere Installation), wurde das Update durchgeführt, es fehlte nur noch der Neustart (worauf ich jedoch aufmerksam gemacht wurde).
Kann es sein, das beim Signaturupdate die Updatedateien für die Programmaktualisierung gleich mit geladen wurden?

gerd88
10.12.10, 17:50
Das ist möglich, habe sowas schon mal bei einer vorherigen Beta im Herstellerforum gelesen.
Das mit Office 2010 ist nur aus "optischen Gründen" für mich interessant, (Funktioniert ja sonst)-geht um Hinweisse in gescannten Mails und ob das Avast Plugin angezeigt wird (Begrüßungs/Startbildschirm bei Office 2010)

Merlin
10.12.10, 20:49
Jetzt im Eingangspost hinzugefügt: Übersetzung der Änderungen der avast! 5.1.807 BETA auf Deutsch

Auggie
11.12.10, 10:49
So ganz richtig ist das wohl nicht, das beim Signaturupdate gleich die Dateien fürs Programmupdate mit heruntergeladen werden.
Das dies bei mir der Fall war, liegt wohl eher daran, das ich das Programmupdate ja schon angestossen hatte:
Habe kurzerhand das System auf einen Snapshot vor avast!-Installation zurückgesetzt.
Jetzt zeigte mir die Benutzerschnittstelle an, es gibt ein neues Signaturupdate und ein Programmupdate.....das Update ließ sich problemlos durchführen.

Was schon bei Version 5.0.x auffiel, fällt auch in 5.1.x auf:
avast! meldet ein ungeschütztes System, obwohl es letztlich nur ein Modul ist, das nicht läuft. Ich finde es das etwas unglücklich formuliert (übersetzt?). Richtiger wäre nicht vollständig geschützt.
Das Modul war übrigens nicht, wie ich angenommen hatte, die FW oder der Netzwerkschutz sondern der Mailschutz, der noch nicht lief.

Merlin
11.12.10, 18:52
Hallo,

eigentlich werden beim Signaturupdate keine Programmupdates heruntergeladen. Seit avast! 5 wird zwar die Engine selbst teilweise mit aktualisiert, die richtigen Programmteile sollten aber erst über das "Programmupdate" aktualisiert werden. Seit der avast! 5 ist es übrigens auch so, dass die eine BETA Version sich direkt über eine darauf folgende aktualisieren lässt. Man muss nur initial irgendwann mal die BETA installiert haben.

tsava!
12.12.10, 12:01
Hallo Jungs,

eine kurze Bitte: könnte mal jemand kurz 2-3 Sätze zur Funktion der Sandbox erläutern?!
Ich hatte, weil ich die Free benutze, bisher noch nichts hiermit zu tun und möchte eigentlich nur mal den genauen Sinn und Zweck im Zusammenhang mit avast! kennen(lernen).

Danke & schönen Sonntag!

Merlin
12.12.10, 13:31
Hallo,

die Sandbox ist eine Art virtuelle Systemumgebung, in der Programme sicher und getrennt vom eigentlichen System ausgeführt werden können. So wird die Gefahr einer Infektion verringert. Im Moment startest du das auf Bedarf, d.h. du entscheidest, ob das Programm in dieser Umgebung ausgeführt werden soll oder nicht. Für die avast! 6 ist allerdings geplant, dass diese Funktion als Bestandteil eines neuen Konzepts eingesetzt wird. D.h. es wird bei unbekannten Programmen generell so verfahren, dass diese erstmal in der Sandbox ausgeführt werden, damit man nicht Gefahr läuft, sich zu infizieren.

Auggie
12.12.10, 15:28
Ich werde meinen Test auf eine 64-Bit-Umgebung unter Windows 7 ausweiten, so kann ich dann die Funktionen testen, die unter 64-Bit noch nicht vollständig implementiert waren.
Eines jedoch solltet ihr bei meinen Berichten nicht vergessen: Es ist eine Beta und eben keine finale Version, d.h. jetzige Fehler werden bis zum Erscheinen der finalen Version behoben sein.

Nur der Info halber: Ist es möglich, wenn später die finale Version erscheint, aus der Oberfläche heraus auf die finale Version upzudaten?

Merlin
12.12.10, 15:32
Nur der Info halber: Ist es möglich, wenn später die finale Version erscheint, aus der Oberfläche heraus auf die finale Version upzudaten?

Ja wird dann auch so geschehen und ist auch so empfohlen.

gerd88
12.12.10, 16:40
@Auggie
Danke das ist gut, falls möglich schau mal wie nun das Verhalten mit Outlook 2010 ist (Plugin Begrüßungsmeldung, Nachricht in empfangene Mails...) Danke.

tiger64
12.12.10, 20:05
Meine Frau hat auf ein älteren Läptop avst 5.1 beta installiert und ich war erstaunt das
man den verhaltensschutz doch aktivieren kann,indem auf "nachfragen" einstellen kann
Vieleicht habe ich was falsch verstanden,aber es hieß doch das der passiv ist,oder doch nicht?

Auggie
12.12.10, 20:25
Ich meine, vor kurzem gelesen zu haben, das Adama schrieb, das der Verhaltensschutz zwar arbeite aber nur Informationen an Alwil schickt (wenn man die Teilnahme an der avast-Community aktiviert hat):
http://forum.avadas.de/threads/749-Verhaltensbasierter-Schutz
Ich denke mal, das war irgendwo in diesem Thread.
Auf meinem Testsystem unter XP konnte ich zumindest beobachten, das für den Verhaltensschutz Statistiken angezeigt werden....müßte dann ja auch Logs eigentlich geben (das sehe ich, wenn XP wieder läuft; muß umstrukturieren, weil die Platte zu klein wurde).

TerraX
12.12.10, 20:29
Ich denke mal, das war irgendwo in diesem Thread.
Hast du recht Auggie, im ersten post.
http://forum.avadas.de/threads/2394-avast!-5.1.807-BETA?p=19618&viewfull=1#post19618

Auggie
12.12.10, 20:29
falls möglich schau mal wie nun das Verhalten mit Outlook 2010 ist (Plugin Begrüßungsmeldung, Nachricht in empfangene Mails...)
Ich denke, das zu dieser Frage das OS nicht wirklich eine Rolle spielt:
avast! läuft ja grundsätzlich unter Win7 wie auch unter XP, so das ich da eigentlich keine großen Abweichungen im Zusammenspiel mit Outlook 2010 bei den einzelnen OS-Versionen erwarten würde.

uweli1967
12.12.10, 22:26
@tiger64 & Co.:cool:
Der Verhaltenschutz von Avast 5.1 Beta ist in dieser wirklich aktiv und erstellt nicht mehr nur Statistiken:cool:Eine Userin bei Rokop die XP verwendet und die aktuelle Avast 5.1 Beta, verkündete das gestern. Ob Avast das bei der Final 5.1 so belässt, weiß ich nicht, aber schön wäre es.

tiger64
12.12.10, 23:09
Das ist gut,vieleicht belässt avast das ja wirklich,wäre super!
Vieleicht ist das aber auch nur zu testzwecken!
Ich habe die beta wieder runter geschmissen,vom läptop meiner Frau!
Mein persönliches Urteil: Nicht lauffäig!
Erst lief alles super,dann hatte ich auf einmal probleme mit den e-mail schutz!
Denn auf einmal hatte mein incredimail keine verbindung mehr zu googlemail,obwohl ich bei incredi alles richtig
eingestellt hatte!
Dann viel auf einmal der netzwerkschutz aus,warum weiss ich nicht!
Dann wollte ich mit systemwiederherstellung das programm entfernen
Auch da kam eine fehlermeldung und es ging nicht!
Dann habe ich es über den eigenen uninstaller und den entfernungstool wieder sauber von der platte gekriegt!
Ohne reste!
Jetzt habe ich wieder die aktuelle version installiert und bin froh das alles doch noch geklappt hat!
Ich dachte zuerst ich müste windows neu aufsetzen!
Ab morgen kann jeden Tag mein neuer pc kommen und eins weiß ich
Die version 5.1 werde ich erst installieren wenn die final ist!
Ein bischen stabiler wurde sie,auch im herstellerforum,schon beschrieben!
Jeder macht ebend andere erfahrungen,auch mit dieser beta!

tsava!
13.12.10, 00:15
Hallo,

die Sandbox ist eine Art virtuelle Systemumgebung, in der Programme sicher und getrennt vom eigentlichen System ausgeführt werden können. So wird die Gefahr einer Infektion verringert. Im Moment startest du das auf Bedarf, d.h. du entscheidest, ob das Programm in dieser Umgebung ausgeführt werden soll oder nicht. Für die avast! 6 ist allerdings geplant, dass diese Funktion als Bestandteil eines neuen Konzepts eingesetzt wird. D.h. es wird bei unbekannten Programmen generell so verfahren, dass diese erstmal in der Sandbox ausgeführt werden, damit man nicht Gefahr läuft, sich zu infizieren.
Danke für die Erklärung, Adama! :)


...dass diese erstmal in der Sandbox ausgeführt werden, damit man nicht Gefahr läuft, sich zu infizieren.
...und danach? Kann man dann irgendwie selbst entscheiden, wenn die Programme außerhalb der Sandbox/normal laufen sollen? :confused:

Merlin
13.12.10, 00:21
...und danach? Kann man dann irgendwie selbst entscheiden, wenn die Programme außerhalb der Sandbox/normal laufen sollen? :confused:

Hallo,

im Moment ist die Sandbox in der Pro und IS Version bereits integriert. Wie die abgespeckte automatische Sandbox Funktion in der Version 6 genau aussieht, kann ich dir aber noch nicht sagen, da arbeitet der Hersteller ja auch noch dran.

Auggie
13.12.10, 10:08
Mein persönliches Urteil: Nicht lauffäig!
Erst lief alles super,dann hatte ich auf einmal probleme mit den e-mail schutz!
Denn auf einmal hatte mein incredimail keine verbindung mehr zu googlemail,obwohl ich bei incredi alles richtig
eingestellt hatte!

Mein Testsystem mit XP läuft quasi die ganze Zeit mit, seit ich die Beta teste, allerdings läuft als Client (noch) Thunderbird und ich nutze (noch) kein GMail.....hier läuft die Beta problemlos.
Daran sieht man mal, wie unterschiedlich eine Beta (und ja eigentlich auch die finale) auf unterschiedlichen Systemkonfigurationen verhält.
Wie Adama schon schrieb: Es ist Beta, Benutzung auf eigene Gefahr.


Dann wollte ich mit systemwiederherstellung das programm entfernen
Auch da kam eine fehlermeldung und es ging nicht!
Dann habe ich es über den eigenen uninstaller und den entfernungstool wieder sauber von der platte gekriegt!
Ohne reste!
Zum Entfernen die Systemwiederherstellung nutzen ist auch der falsche Weg: Entweder den Weg über die die Systemsteuerung gehen oder (idealerweise) das Uninstall-Tool nutzen.

tiger64
13.12.10, 10:30
Den weg über die systemwiederherszellung habe ich gewählt fals ich die beta über den
normalen weg nicht runter kriege!
So ist dann wirklich alles weg!

tsava!
13.12.10, 12:09
Hallo,

im Moment ist die Sandbox in der Pro und IS Version bereits integriert. Wie die abgespeckte automatische Sandbox Funktion in der Version 6 genau aussieht, kann ich dir aber noch nicht sagen, da arbeitet der Hersteller ja auch noch dran.

Ja danke, Adama,
dachte man könnte diesbezüglich eventuell schon Parallelen ziehen.

Wir warten ab und sehen dann, wie's aussieht. ;)

Merlin
13.12.10, 19:21
dachte man könnte diesbezüglich eventuell schon Parallelen ziehen.

Kann man auch ein wenig. Ich habe in dem Thema im Smalltalk schon kurz erläutert wie das ungefähr aussehen soll. Die Technik, die dahintersteckt ist die gleiche wie bei der jetzigen Sandbox, nur dass diese sich in der zukünftigen Free Version nicht manuell nutzen lässt, sondern bei unbekannten Programmen automatisch zum Einsatz kommt. Die Frage ist nur noch, aufgrund welchen Parametern dort die Entscheidung fällt, dass ein Programm in der Sandbox ausgeführt wird. Um da näheres zu erfahren, müssen wir uns dann noch ein bisschen gedulden.

Auggie
13.12.10, 20:16
Aufgrund der Erfahrungen von tiger64 habe ich Win 7 x64 die laufende 5.0.677 mit dem Uninstalltool deinstalliert und anschließend die aktuelle Beta installiert.....alles lief problemlos.
Auch die anschließende Installation von avast! 5.1.807 Beta verlief problemlos.
Direkt nach der Installation wurde mir, wie schon XP x86 eine Startzeitprüfung angeboten, auch die lief problemlos.
Allerdings habe ich den Eindruck, das die gegenüber meinem XP-System spürbar langsamer läuft.....um das zu überprüfen, kommt morgen eine Prüfung mit einem frisch gestarteten Wirtssystem (der Ram-Verbrauch momentan ist sehr viel höher als sonst normal).

tsava!
14.12.10, 01:53
@Adama

Super, vielen Dank für die ergänzende Erklärung. Dann bin ich ja mal gespannt, wie das Endergebnis aussieht...;)

Merlin
16.12.10, 17:15
Hallo,

heute ist die BETA aktualisiert worden, die neue Versionsnummer lautet: avast! 5.1.822

Ich habe meine Ursprungspost entsprechend angepasst.

gerd88
16.12.10, 17:47
Changelog zu dieser Beta besagt das die bisher aufgetretenen Probleme mit dieser Version behoben sein sollen. Mehr ist (mir) bisher nicht bekannt.

Auggie
16.12.10, 18:16
Neues von der Testfront:
Die bewußt ohne Lizenz installierte Beta meldet mir gerade, das mein System vollkommen ungeschützt; über die Benutzerschnittstelle ließ sich der Verursacher schnell ausmachen: Ablauf der Lizenz.....nach nicht mal 30 Tagen.
Fazit: Echtzeitschutz läuft nicht mehr und lässt sich auch nicht wieder aktivieren, Updates werden nicht mehr heruntergeladen.
Nun muß ich erst mal die Lizenz einspielen, damit es mit dem Test weiter gehen kann.

Ich frage mich natürlich jetzt, ob es in der finalen Version auch so ist, das weder Echtzeitschutz läuft noch Updates geladen werden.
Zumindest ich bin davon ausgegangen, das das Programm selbst läuft, nur das keine Updates mehr zu bekommen sind; das könnte ich persönlich noch verkraften.

Update: Meine Installation ist doch schon älter, genauer gesagt, Installationsdatum vom 19.11.2010, der Testzeitraum von 30 Tagen wird erfüllt....das danach die Lizenz erneuert werden muß, ist logisch.
Nach dem Einfügen der Lizenz gab es auch wieder Updates.

Update manuell durchgeführt...das schien mir etwas länger als gewöhnlich gedauert zu haben....Signaturen und Programm wurden aktualisiert.
Seltsamerweise wurde diesmal kein Neustart, wie bisher üblich gefordert.
Der Echtzeitschutz lief auch wieder, jedoch war die FW deaktivert, sie ließ sich manuell auch nicht einschalten.
Da ein Neustart nicht gefordert wurde, habe ich den manuell durchgeführt. Nach dem Neustart lief auch die Suite wieder vollständig.

Auggie
17.12.10, 02:16
Ich schätze mal, bei meinem Update ist einiges daneben gegangen:
Nachdem ich vorhin das System hochgefahren hatte, fiel als erstes das fehlende Tray-Icon auf.
Zweites Problem: Es dauerte ca. 10 Minuten, bis das System reagiert hat auf meine Eingaben. Bis dahin kein Internetzugang und das Netz- und Freigabecenter ließ sich nicht öffnen. Mittlerweile geht der Netzzugang wieder.
Drittes Problem: Die Benutzeroberfläche läßt sich nicht öffnen.....die Dienste laufen alle, wie sie sein sollen, und ProcessExplorer meldet mir die Dienste ebenso.
Das Wartungscenter meldet mir ein deaktivertes avast!
133
Ich werde morgen von meinem Deinstallationsversuch berichten.....der zwangsläufig im Abgesicherten Modus erfolgen muß (in der Hoffnung, das sich dort die Oberfläche öffnen läßt und ich den Selbstschutz deaktivieren kann. Sonst bleibt nur das Rücksetzen des Systems als Option).
Testumgebung: Win 7 x64 und avast! Internet Security

Man sieht, man tut gut daran, eine Beta nicht auf einem Produktivsystem zu testen.

Update:
Updatevorgang unter WinXP SP3 x86 verlief erfolgreich, hier wurde, wie zu erwarten war, auch zum Neustart aufgefordert.
Um zu überprüfen, ob unter Win 7 nur das Update daneben ging (was ich mal vermute) oder es mit dem 64-Bit-System zusammenhängt, werde ich die alten Beta 5.1.807 erneut installieren und noch einmal versuchen, aus der Oberfläche upzudaten.
Man sollte bei einem manuellen Update auf eines achten:
Da avast! nach einem Neustart die Signaturen updated, sollte man das Programmupdate erst anstoßen, wenn die Signaturaktualisierung abgeschlossen ist.....vorher hängt der gleichzeitige Updateversuch für das Programmupdate ohne Fehlermeldung bei der Initialisierung der Updateanfrage.

Auggie
17.12.10, 07:48
Sah es gestern noch danach aus, als müßte ich auf meinem Win 7 x64-System avast! deinstallieren, so präsentiert sich heute ein ganz normales Bild:
134
Der Screenshot wurde eine knappe Minute nach Start des Systems aufgenommen.
Alle Schutzmodule liefen.
Die Probleme, von denen ich gestern berichtet habe, sind wie weg geblasen, als wäre nichts gewesen.....ohne Eingriff von mir.
Ich werde jetzt mal das Ereignisprotokoll nach Fehlern durchforsten.

Auggie
17.12.10, 08:18
Ursache für das Problem war wohl, trotz anders anderer Anzeige des ProcessExplorers, das der avast!-Dienst nicht richtig gestartet ist:
135
Die Ereignisanzeige zum fraglichen Zeitpunkt sagt jedenfalls etwas anderes als gestern der ProcessExplorer.
Die beiden letzten Screenshots sind eine Warnung, die seltsamerweise nur auf dem ersten Blick etwas mit der Situation gestern zu tun hat.....sie taucht bei jedem Neustart auf (wohl eher bedingt durch die Virtualisierung).
137136

Merlin
17.12.10, 09:28
Man sieht, man tut gut daran, eine Beta nicht auf einem Produktivsystem zu testen.

Exakt, weiterhin sieht man, dass auch wenn im Herstellerforum immer euphorisch vom Release einer bestimmten Version zu einem bestimmten Zeitpunkt gesprochen wird, man das mit Vorsicht geniessen sollte. Erfahrungsgemäß verzögert sich das geplante Release immer um mindestens einen Monat.

Es gibt übrigens noch sehr viele Probleme, die mit dem neuen Pre-Release avast! 5.1.822 BETA aufgetreten sind, u.a. wieder Freezes und Bluescreens.

Auggie, Danke für deine ausführliche Berichterstattung!

Auggie
17.12.10, 16:16
Auggie, Danke für deine ausführliche Berichterstattung!
Danke für das Lob.
Für mich ist die Beta ehrlich gesagt kein Grund, aus dem Häuschen zu geraten, auch weil es eben "nur" ein größeres Minor-Update ist, und nicht, wie beim Übergang zur Version 5, ein großes Major-Update.
Die Veränderungen/Verbesserungen spiegeln sich für mich doch eher im Detail ab, ein weiterer Schritt hin zum Marktführer, wenn man so will....aber die Konkurenz schläft auch nicht.....kein Grund, sich auszuruhen, weil mit der Version 5 imho ein großer Wurf gemacht wurde.
Ich werde jetzt den parallel zu diesem Test laufenden Test eines externen Verhaltensschutzes kurzfristig unterbrechen und wieder den avast!-Verhaltensschutz installieren, da es mit der jetzt aktuellen Beta einige Probleme gibt, wie man im Herstellerforum lesen kann.

Update: Das avast!-Verhaltensschutzmodul ist jetzt, wie angekündigt, wieder installiert, über eine Änderungsinstallation. Hier wurde, wie ich es schon beim Update auf die Beta 822 erwartet hätte, auch ein Neustart angefordert.
Die Änderungsinstallation verlief problemlos, auch wenn es einen kurzen Moment dauerte, bis avast! vollständig alle Module geladen hatte.
Die Statusmeldung besagte gar, das der Echtzeitschutz gar nicht aktiv wäre, trotzdem lief z.B. schon der Dateischutz.
Da das insbesondere bei unerfahrenen Usern durchaus zu Verwirrung oder gar Panik führen kann, sollte der Hersteller hier imho noch etwas nachbessern und die Meldung anpassen (auch wenn der Hersteller hier nicht mitliest).
Spaßeshalber habe ich mal versucht, während dieser Zeit den Echtzeitschutz über die Oberfläche zu aktivieren.....da tat sich nichts.
Nach gefühlten 1-2 Minuten war der Schutz vollständig.

Gibt es eigentlich so etwas wie eine Startprotokollierung?

Merlin
21.12.10, 09:23
Hallo,

ein neues Build ist erschienen: avast! 5.1.835 BETA. Mein Eingangspost wurde entsprechend angepasst. Diese Version soll die letzte vor dem offiziellen Release darstellen, es handelt sich also um eine Art Release Candidate.

Merlin
27.12.10, 13:24
Hallo,

ein neues Build ist erschienen: avast! 5.1.849 BETA. Mein Eingangspost wurde entsprechend angepasst.

240670
27.12.10, 16:27
Windows7 64bit Wartungscenter wird die Firewall von Avast nicht erkannt als wäre sie nicht vorhanden!

Catweezel
27.12.10, 16:34
wie meinst du das ? Gibt es eine Fehlermeldung ?
Was steht denn konkret unter Netzwerkfirewall für ein Text ?

Auggie
27.12.10, 17:02
Einfach mal diese Weg durchführen: http://forum.avadas.de/threads/2222-avast!-4-5-FAQ-Knowledgebase?p=17361&viewfull=1#post17361
Das Wartungscenter funktioniert leider immer noch nicht so wie es soll; so lang avast! selbst anzeigt, das alle Module laufen, ist alles okay.

240670
27.12.10, 17:12
Weiß zwar nicht warum es hierher verschoben wurde aber ist auch egal. Wollte einen Fehler der BETA 5.1.849 melden. Keine Fehlermeldung wird einfach nicht erkannt.

uweli1967
27.12.10, 17:19
Wie jetzt 240670? Hast du die BETA 5.1.849 aktuell installiert und bei dieser kommt die Fehlermeldung mit der Firewall? Wenn ja darfst du dich nicht wundern, denn eine BETA ist noch keine Final.

240670
27.12.10, 17:22
Ich wunder mich nicht darüber,wollte es nur melden damit es in der Final behoben ist. Mehr nicht.

Merlin
27.12.10, 17:25
Ich wunder mich nicht darüber,wollte es nur melden damit es in der Final behoben ist. Mehr nicht.

Hallo,

ich habe deine Posts dann in das entsprechende Thema für die avast! BETA verschoben.

uweli1967
27.12.10, 17:26
Also tritt der Fehler mit der Avast-Firewall die vom Wartungscenter nicht erkannt wird bei der aktuellen BETA auf?

Ich wunder mich nicht darüber,wollte es nur melden damit es in der Final behoben ist. Mehr nicht. Das ist ja ein feiner Zug von dir, aber der Hersteller liest eher wenig in unserem Forum mit. Besser wäre es, das im Hersteller-Forum zu posten wenn du möchtest.

240670
27.12.10, 17:46
Würde ich , aber Englisch kann ich nicht!

uweli1967
27.12.10, 18:19
Geht mir genauso, mein Englisch ist sehr schwach:(Aber wie man Alwil bzw Avast kennt, werden die bald nachbessern wegen der Firewall und dem Wartungscenter.

Catweezel
27.12.10, 18:44
Weiß zwar nicht warum es hierher verschoben wurde aber ist auch egal. Wollte einen Fehler der BETA 5.1.849 melden. Keine Fehlermeldung wird einfach nicht erkannt.

sorry, ich hatte das vorhin hier herausgetrennt, da ich dachte, es handelt sich um das aktuelle Release und nicht die Beta.
Dass das deutsche Forum nicht der richtige Platz für das Posten von Problemstellungen der Beta sind, wurde ja schon klargestellt.
Aber eine konkrete Antwort auf meine zweite Frage kam trotzdem nicht.... suboptimal so eine Posterei....;)

Auf einem Produktivsystem läuft das Ganze doch hoffentlich nicht.....:confused:

240670
27.12.10, 19:13
Nein auf einem Zweitrechner den ich immer zum Testen nutze.

240670
27.12.10, 19:33
Nein läuft auf einem Zweitrechner. Und warum ich es hier melde ganz einfach, Englisch kann ich nicht und es werden genug User da sein die es auch weiter leiten können. Und dafür ist doch ein Forum da um Probleme zu lösen und zu melden und Fragen zu stellen und Antwort zu geben. Wenn nicht dann braucht man auch kein Forum oder?

gerd88
27.12.10, 19:38
Schon richtig, aber hier ist nicht das Herstellerforum, da würden Fehler bezüglich der Beta besser hingehören, es gibt dort auch einen deutschen Bereich, falls das eigene Englisch nicht ausreicht.

Merlin
27.12.10, 19:59
Nein läuft auf einem Zweitrechner. Und warum ich es hier melde ganz einfach, Englisch kann ich nicht und es werden genug User da sein die es auch weiter leiten können. Und dafür ist doch ein Forum da um Probleme zu lösen und zu melden und Fragen zu stellen und Antwort zu geben. Wenn nicht dann braucht man auch kein Forum oder?

Naja generell behandeln wir hier eher Fragen, die finale Versionen betreffen. Gerade bei Problemen mit dem Sicherheits- bzw. Wartungscenter ist es auch nicht unbedingt gesagt, dass es an der BETA liegt. Hier haben wir ein paar Lösungsansätze zu dem Thema: http://forum.avadas.de/threads/2222-avast!-4-5-FAQ-Knowledgebase?p=17361&viewfull=1#post17361
Abgesehen davon, dass es wenn dann auch eher ein geringeres Problem wäre, da im Moment weitaus größere Probleme mit der BETA existieren. Meine Empfehlung lautet daher einfach die finale Version abzuwarten und wenn das Problem dann immer noch existiert, sich hier nochmal zu melden. Zu dem Englisch Problem: In dem Fall das Problem betreffend der BETA im deutschen Bereich des englischen Forums zu melden hilft nicht wirklich weiter, dort liest der Hersteller genau so wenig mit wie hier. Die einzig erfolgsversprechende Variante wäre im BETA Forum des englischen Forums aus Englisch zu posten. Alternativ bleibt nur das Warten.

240670
27.12.10, 20:25
OK verstanden. Die Final hat nicht das problem mal ebend so neben bei.

Catweezel
27.12.10, 21:19
Die Final hat nicht das problem mal ebend so neben bei.
du meinst, die aktuelle Version...:confused:
Ja, wissen wir...;)

Auggie
28.12.10, 16:39
.......da ich dachte, es handelt sich um das aktuelle Release und nicht die Beta.
Das war zum Anfang der Threaderstellung imho auch nicht ganz klar....wenn ich mich recht entsinne, hatte sogar ich selbst auf den Thread geantwortet und den Link in der FAQ als Weg genannt, in der Annahme, es handele sich um die finale Version.

So löblich es auch ist, durch die Installation einer Beta mithelfen zu wollen, die finale Version zu verbessern, man sollte dann schon des englischen halbwegs mächtig sein, da der Großteil der Software nunmal von ausländischen Herstellern entwickelt wird, Englisch in der Computer-Branche gang und gebe ist und nicht jeder Hersteller ein deutschsprachiges Forum unterhält.
Das dafür nur der Hersteller als Ansprechpartner infrage kommt, sollte man eigentlich auch wissen, denn der unterhält dafür extra dafür eingerichtete Bereiche wie Bug-Listen etc.

Merlin
30.12.10, 09:46
Hallo,

ein neues Build ist erschienen: avast! 5.1.857 BETA. Mein Eingangspost wurde entsprechend angepass

uweli1967
30.12.10, 23:51
Es gibt eine neue Beta: build number 5.1.861

Hi again,

WE have just released yet another avast beta refresh (build number 5.1.861). Compared to the previous beta build (5.1.857), it's supposed to solve these issues:

- the Behavior Shield related issues (typically on 64-bit OSes)
- HTTP pipelining support in Web Shield (Opera users will appreciate this)
- a possible race condition in aswSP.sys that could lead to a system hang
- an Outlook antispam plugin problem
- removed limit on the number sites in the Site Blocking feature (AIS)

To me, this build feels like it's in a really good shape and I wouldn't hesitate calling it a "release candidate". Our plan was to release v5.1 before the end of the year, so WE still have some 27 hours to make this happen... hopefully, if you guys confirm that this beta works OK, it will go live tomorrow as an official update.

The only thing that WE know is not fixed is the issue described by Sparxx here -- http://forum.avast.com/index.php?topic=68316.0 -- this is most likely related to the antirootkit scan. But this can be solved by a subsequent VPS update (as the antirootkit engine is located in the VPS).


As always, your feedback is very appreciated.

Download links:
Free AV: http://files.avast.com/files/beta/5.1.861/setup_av_free.exe
Pro AV: http://files.avast.com/files/beta/5.1.861/setup_av_pro.exe
IS: http://files.avast.com/files/beta/5.1.861/setup_ais.exe

(Users of a previous beta can go to this build by simply invoking the Program Update feature from within the avast! UI.)


Thanks
Vlk

Merlin
31.12.10, 00:33
Hallo,

Danke für den Hinweis. Eingangspost ist wie immer aktualisiert.

gerd88
31.12.10, 00:47
Klingt ja gut, wenn alles klappt wird es sogar dieses Jahr noch was mit der 5.1-wenn es doch erst nächstes Jahr wird, was solls. Wichtiger als das Veröffentlichungsdatum ist ja das es funktioniert.

gerd88
31.12.10, 13:25
Und noch eine neue Version

now updated to version 5.1.862. There are only 2 changes (compared to 5.1.861) in this version:

- modified Behavior Shield on 64-bit Windows (solves the problem reported by calcu007). This maybe solves some of the outstanding x64 BehavShield-related problems as well (please test)
- hopefully fixed the registration of the Avast firewall with the Windows Security Center (please test). You will need to do a clean install for this (updating from 861 won't have any effect on this).


As always, your feedback is very appreciated.

Download links:
Free AV: http://files.avast.com/files/beta/5.1.862/setup_av_free.exe
Pro AV: http://files.avast.com/files/beta/5.1.862/setup_av_pro.exe
IS: http://files.avast.com/files/beta/5.1.862/setup_ais.exe

(Users of a previous beta can go to this build by simply invoking the Program Update feature from within the avast! UI.)


Thanks
Vlk

Merlin
31.12.10, 15:07
Windows7 64bit Wartungscenter wird die Firewall von Avast nicht erkannt als wäre sie nicht vorhanden!

Sollte im letzten Build avast! 5.1.862 BETA behoben worden sein, allerdings musst du hierfür mit dem Uninstall Tool neu installieren (siehe meinen Eingangspost - Änderungen).