PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Geschlossen AAVM Sub-System hat einen RPC-Fehler festgestellt



ctra
26.01.07, 20:43
Guten Abend zusammen,

ich hab seit heute nachmittag ein kleines Problem mit meiner avast home edition. Seit dem ersten Hochfahren heute ist das kleine avast-icon in der task leiste mit einem rot durchgestrichenen kreis versehen.
"avast! Zugriffs-Scanner: 0 Provider gesamt, 0 aktiv"

Ich kann das Programm zwar noch als Scan benutzen, aber sobald ich auf das kleine icon klicke, kommt die Meldung " avast!: Das AAVM Sub-System hat einen RPC-Fehler festgestellt."

Bitte um Hilfe oder evtl. Tipps zum wieder einwandfreien Laufen des Programms :)

PS: Benutze das Programm jetzt seit über einem Jahr und habe diesen Zustand zum ersten Mal. Update erst vor 3 Tagen.

Catweezel
27.01.07, 20:10
hi ctra,

bei den FAQ's auf der AVAST-Homepage (http://www.avast.com/eng/faq-red-circle.html) gibt es dazu diesen Hinweis :


Q: There´s a red circle on avast! a-ball icon in system tray and when I click on it, the error message appears saying "the AAVM subsystem detected a RPC error". How to fix this?

A: First, use Windows Update to be sure that all Windows components (including "RPC") is up to date. Then restart your computer and check if the problem persists. If it persists, follow these instructions:

Right-click the icon MY COMPUTER and select MANAGE.
In left column unroll SERVICES AND APPLICATIONS.
Click on SERVICES.
In the right column, look at the state of service avast! Antivirus.
If the service isn't set to start automatically, set it that way (right-click it and select PROPERTIES and the STARTUP TYPE set to AUTOMATIC). Restart the computer after making the change.
If it was already set to "Automatic", check the status of the service. If it not "Started", try to start it (right-click it and select START).
If the service cannot be started, your avast! installation might be corrupted. Try repairing the avast! installation: click START -> CONTROL PANEL -> ADD/REMOVE PROGRAMS -> avast! Antivirus -> CHANGE/REMOVE and select REPAIR.
This solution works on Windows NT, 2000, XP and 2003 only.

Gruss Catweezel

ctra
28.01.07, 18:19
nabend,

ja den hab ich mir natürlich als erstes angeguckt, hab damit das problem aber nicht lösen können. Ich hab dann noch einige andere Sachen probiert hat alles nicht funktioniert, und als ich dann 3 std später nochmal geguckt habe hatte sich das problem von alleine gelöst.

Die Scanner liefen wieder und kein roter kreis mehr. Also für alle, die irgendwann vielleicht mal dasselbe Problem haben sollten, vielleicht einfach mal ein bißchen abwarten.

Vielen Dank für deine Mühen ;)

kuddel
15.02.07, 20:46
hi ctra,

bei den FAQ's auf der AVAST-Homepage (http://www.avast.com/eng/faq-red-circle.html) gibt es dazu diesen Hinweis :


Q: There´s a red circle on avast! a-ball icon in system tray and when I click on it, the error message appears saying "the AAVM subsystem detected a RPC error". How to fix this?

A: First, use Windows Update to be sure that all Windows components (including "RPC") is up to date. Then restart your computer and check if the problem persists. If it persists, follow these instructions:

Right-click the icon MY COMPUTER and select MANAGE.
In left column unroll SERVICES AND APPLICATIONS.
Click on SERVICES.
In the right column, look at the state of service avast! Antivirus.
If the service isn't set to start automatically, set it that way (right-click it and select PROPERTIES and the STARTUP TYPE set to AUTOMATIC). Restart the computer after making the change.
If it was already set to "Automatic", check the status of the service. If it not "Started", try to start it (right-click it and select START).
If the service cannot be started, your avast! installation might be corrupted. Try repairing the avast! installation: click START -> CONTROL PANEL -> ADD/REMOVE PROGRAMS -> avast! Antivirus -> CHANGE/REMOVE and select REPAIR.
This solution works on Windows NT, 2000, XP and 2003 only.

Gruss Catweezel