PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Gelöst for Mac: läuft nicht



Knut
07.04.09, 09:39
Wie oben bereits geschrieben:
Das Programm Avast läuft einfach nicht unter Mac OSX 10.4.11. Auch nicht nach mehrmaliger Installation. Und sauber Deinstallieren lässt es sich auch nicht mehr. Bei jedem Start des Rechners wird es automatisch mitgestartet, sucht dann natürlich vergebens Dateien, die durch die teilweise Deinstallation entfernt wurden, und öffnet schließlich eine Fehlermeldung.
Höchst nervig und auch sehr ärgerlich!
Wie werde ich dieses unzulänglich gearbeitete Programm wieder los?
(Für Windows gibt es ja zumindest ein extra Deinstallationsprogramm, nur leider funktioniert das für den Mac natürlich nicht)

Merlin
07.04.09, 18:45
Wie werde ich dieses unzulänglich gearbeitete Programm wieder los?

Unzulänglich gearbeitetes Produkt (es heisst übrigens nicht "gearbeitetes"...) oder unzulänglich konfiguriertes System ? Letzteres liegt wohl am User :wink:

Zur Frage:

1) Da Mac 10.4.x verwendet wird, werden wahrscheinlich noch diverse Einträge im Launch Daemon vorhanden sein. Hierzu das Tool "launchctl" über die Kommandozeile aufrufen und diese Einträge entfernen (Hilfe hierzu in der Manpage von launchctl, ebenfalls erreichbar über den Kommandozeilenbefehl "man launchctl").

2) Danach avast! Mac Dienst und Agenten beenden (z.B. über die Tray Icons oder über "ps aux" und "kill -9 <pid>) und avast! dann auf den Papierkorb ziehen. Danach sollte avast! entfernt sein.